summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-02-13 11:03:11 -0500
committerMike Gilbert <floppym@gentoo.org>2018-02-13 11:03:36 -0500
commit7346a1c028fb1d242b50c3a1cff4fd49d88af224 (patch)
treeb3087c0204c2f09282d97e95aeae97c4d5687e2b /sys-fs/udev/udev-9999.ebuild
parentgames-fps/urbanterror: Cleanup old version. (diff)
downloadgentoo-7346a1c028fb1d242b50c3a1cff4fd49d88af224.tar.gz
gentoo-7346a1c028fb1d242b50c3a1cff4fd49d88af224.tar.bz2
gentoo-7346a1c028fb1d242b50c3a1cff4fd49d88af224.zip
sys-fs/udev: bump to 237
This update also drops the workaround for missing secure_getenv, which hasn't worked properly since the build system was switched to meson. Bug: https://bugs.gentoo.org/443030 Closes: https://bugs.gentoo.org/647260 Package-Manager: Portage-2.3.24_p18, Repoman-2.3.6_p99
Diffstat (limited to 'sys-fs/udev/udev-9999.ebuild')
-rw-r--r--sys-fs/udev/udev-9999.ebuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 5992ed3480b6..3b794e7c3ded 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -78,14 +78,6 @@ pkg_setup() {
}
src_prepare() {
- if ! [[ ${PV} = 9999* ]]; then
- # secure_getenv() disable for non-glibc systems wrt bug #443030
- if ! [[ $(grep -r secure_getenv * | wc -l) -eq 27 ]]; then
- eerror "The line count for secure_getenv() failed, see bug #443030"
- die
- fi
- fi
-
cat <<-EOF > "${T}"/40-gentoo.rules
# Gentoo specific floppy and usb groups
ACTION=="add", SUBSYSTEM=="block", KERNEL=="fd[0-9]", GROUP="floppy"
@@ -97,11 +89,6 @@ src_prepare() {
)
default
-
- if ! use elibc_glibc; then #443030
- echo '#define secure_getenv(x) NULL' >> config.h.in
- sed -i -e '/error.*secure_getenv/s:.*:#define secure_getenv(x) NULL:' src/shared/missing.h || die
- fi
}
meson_multilib_native_use() {
@@ -142,10 +129,10 @@ src_configure() {
multilib_src_compile() {
# meson creates this link
- local libudev=$(readlink src/libudev/libudev.so.1)
+ local libudev=$(readlink src/udev/libudev.so.1)
local targets=(
- src/libudev/${libudev}
+ src/udev/${libudev}
)
if multilib_is_native_abi; then
targets+=(
@@ -169,10 +156,10 @@ multilib_src_compile() {
}
multilib_src_install() {
- local libudev=$(readlink src/libudev/libudev.so.1)
+ local libudev=$(readlink src/udev/libudev.so.1)
into /
- dolib.so src/libudev/{${libudev},libudev.so.1,libudev.so}
+ dolib.so src/udev/{${libudev},libudev.so.1,libudev.so}
insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc