summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 10:25:21 +0000
committerSam James <sam@gentoo.org>2022-01-13 10:25:28 +0000
commitf4cae72bff7ab14e21f3f73f97308e0b035db769 (patch)
tree8184064e3223ebe8d0842c3ac7f6933a97a7306e /sys-fs
parentprofiles/arch/x86: mask tomcat and deps that depend on jdk11 (diff)
downloadgentoo-f4cae72bff7ab14e21f3f73f97308e0b035db769.tar.gz
gentoo-f4cae72bff7ab14e21f3f73f97308e0b035db769.tar.bz2
gentoo-f4cae72bff7ab14e21f3f73f97308e0b035db769.zip
sys-fs/quota: fix build on musl
Closes: https://bugs.gentoo.org/713390 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/files/quota-4.06-musl-cdefs.patch20
-rw-r--r--sys-fs/quota/quota-4.06.ebuild18
2 files changed, 30 insertions, 8 deletions
diff --git a/sys-fs/quota/files/quota-4.06-musl-cdefs.patch b/sys-fs/quota/files/quota-4.06-musl-cdefs.patch
new file mode 100644
index 000000000000..286fc481b6b3
--- /dev/null
+++ b/sys-fs/quota/files/quota-4.06-musl-cdefs.patch
@@ -0,0 +1,20 @@
+https://sourceforge.net/p/linuxquota/code/ci/1959f3768a284315250acd4d17a9f5ef0b8ea189/tree/quota.h?diff=43b6e31f39edbe7de4f4feeef4d0cf6be093e021
+https://bugs.gentoo.org/713390
+--- a/quota.h
++++ b/quota.h
+@@ -1,7 +1,6 @@
+ #ifndef GUARD_QUOTA_H
+ #define GUARD_QUOTA_H
+
+-#include <sys/cdefs.h>
+ #include <sys/types.h>
+ #include <stdint.h>
+
+@@ -182,6 +181,6 @@
+ #endif
+ #endif
+
+-long quotactl __P((int, const char *, qid_t, caddr_t));
++long quotactl(int, const char *, qid_t, caddr_t);
+
+ #endif /* _QUOTA_ */
diff --git a/sys-fs/quota/quota-4.06.ebuild b/sys-fs/quota/quota-4.06.ebuild
index 3ca2ad3dd987..1c4cd2de9211 100644
--- a/sys-fs/quota/quota-4.06.ebuild
+++ b/sys-fs/quota/quota-4.06.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,21 +23,22 @@ RDEPEND="
)
rpc? (
elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
- net-libs/libtirpc
+ net-libs/libtirpc:=
net-libs/rpcsvc-proto
)
tcpd? ( sys-apps/tcp-wrappers )
"
DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-PDEPEND="
- rpc? ( net-nds/rpcbind )
-"
+BDEPEND="nls? ( sys-devel/gettext )"
+PDEPEND="rpc? ( net-nds/rpcbind )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-cdefs.patch
+)
src_prepare() {
default
+
eautoreconf
}
@@ -50,6 +51,7 @@ src_configure() {
$(use_enable rpc)
$(use_enable rpc rpcsetquota)
)
+
econf "${myeconfargs[@]}"
}