summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-12-08 20:01:10 -0500
committerMike Pagano <mpagano@gentoo.org>2016-12-08 20:01:21 -0500
commit2572879d9f7036227f43ec43dcd85b6f40889b4e (patch)
tree24de7fc3be4345a2bd7dd487733792e630e10c5d /sys-kernel/gentoo-sources/gentoo-sources-3.12.68-r1.ebuild
parentsys-kernel/gentoo-sources: For Linux 3.18.X, fix race condition in packet_set... (diff)
downloadgentoo-2572879d9f7036227f43ec43dcd85b6f40889b4e.tar.gz
gentoo-2572879d9f7036227f43ec43dcd85b6f40889b4e.tar.bz2
gentoo-2572879d9f7036227f43ec43dcd85b6f40889b4e.zip
sys-kernel/gentoo-sources: For Linux 3.12.X, fix race condition in packet_set_ring. CVE-2016-8655. Bug #601926.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-3.12.68-r1.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.12.68-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.12.68-r1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.12.68-r1.ebuild
new file mode 100644
index 000000000000..76cff234d032
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.12.68-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="66"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}