summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-08-01 20:48:04 -0400
committerMike Pagano <mpagano@gentoo.org>2021-08-01 20:48:04 -0400
commit49a6278e72a5e0bba3fb9a67dd3bce0566e598f1 (patch)
treecb6f25a2733a19a0017715082313169a0d1ac711 /sys-kernel
parentnet-misc/sslh: PCRE is an unconditional dependency (diff)
downloadgentoo-49a6278e72a5e0bba3fb9a67dd3bce0566e598f1.tar.gz
gentoo-49a6278e72a5e0bba3fb9a67dd3bce0566e598f1.tar.bz2
gentoo-49a6278e72a5e0bba3fb9a67dd3bce0566e598f1.zip
sys-kernel/git-sources: Linux patch 5.14-rc4
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.14_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index a234eead3ccf..103c805640a7 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.13.tar.xz 119297284 BLAKE2B 9c4c12e2394dec064adff51f7ccdf389192eb27
DIST patch-5.14-rc1.patch 68962675 BLAKE2B 0f5bc5de6167c3f2b884354a54dd9cbedc3d89508e9861ef7bebe181c650ab9dde4f604f8c5e77c27eef9c213345ac85d8c65e0c9a7f48cc918a2ad681fc3e59 SHA512 e68522063c08adf11c8cbdb86aa439347ed833be77cf189655e14df6e2e9c18479a69bfbcb8258411e896f32b15c53f8df04402f6ba0434179c3d37e0cabc5b9
DIST patch-5.14-rc2.patch 69403130 BLAKE2B 56a55e40625fbdf9b9324ffbdae401bc9202cb63ea3d787960a93c0f72a10aeffcc7e2988f873ca916d434981e949c1ff2e1e09941d93ff119c5d9da295e3628 SHA512 5962339c1e84c2e760d76aca6c4d0f74fbc80bd997f55f85ad22745d5db43846ad86270862206684304a42e3b25d1c505df58da4e0f0460b82e7c7a12e97a70b
DIST patch-5.14-rc3.patch 69715862 BLAKE2B bf826bfaf1968b2da2f074bb16ac82237c41d8b57e689545a88c64f125ece052e24557a82e00b37761ece2f440498cf0ffa848cfad4fae18380bd3fa0e637ac0 SHA512 56199a49b579f3511605a4a90dd8a2f5c9c904705bcd3036933e748864b4fe10cef5f084cf39227b959776df0e2509776f12c9d6d9f0c12947613ca2dba86b26
+DIST patch-5.14-rc4.patch 69955713 BLAKE2B b4e3051cbba62cf937072205c29116362578be25dec7d5b25d020ffb4e634855be2771c152a36b1d40249692aceed0e70edc25479aad1ac99399dbec878fd97b SHA512 0d62ef70193c4bcb2b13637878e5c6d163d59cdcf00ec1447fe356e86853735e460706aba783a1942de0f32dc5b3fc8d95a012ff6cdcb6ab0d398556a2aa3bf4
diff --git a/sys-kernel/git-sources/git-sources-5.14_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.14_rc4.ebuild
new file mode 100644
index 000000000000..d43c5c0ce00d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.14_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.13"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}