summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2017-04-16 19:59:03 -0400
committerMike Pagano <mpagano@gentoo.org>2017-04-16 19:59:17 -0400
commit4a8f9e636d6a25d8c97269275abfce607db07236 (patch)
treed506eaf3f3966be07f5077364dca0a173f7950b3 /sys-kernel
parentdev-db/sqliteman: Fix building with qscintilla-2.10 (diff)
downloadgentoo-4a8f9e636d6a25d8c97269275abfce607db07236.tar.gz
gentoo-4a8f9e636d6a25d8c97269275abfce607db07236.tar.bz2
gentoo-4a8f9e636d6a25d8c97269275abfce607db07236.zip
sys-kernel/git-sources: Linux patch 4.11-rc7
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.11_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index bd3b40273727..685d62f851ae 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-4.11-rc3.xz 6296096 SHA256 42bc915a0fec22541716a32167dab53f8f3417e31b
DIST patch-4.11-rc4.xz 6365804 SHA256 04789539b677a10dae8080e35267923b9dbe570bf896986dfc2a4401c079b1cb SHA512 d92866ffe4997a5e489c034fc1c378d7e588f76cfa18d642854ce0bf412cdbc82d8e850d6665fa5175084ec0b7662b0f53435231d2b46b13cefbb9ba63f73791 WHIRLPOOL 6de1bd0a9d45ca4e085e53529118aa9d39784c76b9f579d4b29296de4b33a326bbbb833bc2b8b2d1a6e05c08d08f0824541302ed537e78d76ffdec3f0532eaaf
DIST patch-4.11-rc5.xz 6408648 SHA256 6a73243ddc790655672d7b93a7bcf6d232f452903b68212c14e2b16f37119810 SHA512 9b8b728eb8bb679d012c90f878739f02a3c9d13eb916248550fc61fad5a7ac5a0aee9c8166ff0c8b3180b96679f69ffbb5f79992f02a1693fd2c3616df1f6dd1 WHIRLPOOL 7a5be6360549fcdbf1bd4ffb8f77838ba6bcaa3dd7a3048bb0b12b05a246063389ef20a00352f3cd3d6db37cbab144c33bdd68e460276b56069d07c4b3132220
DIST patch-4.11-rc6.xz 6378364 SHA256 876a6db3ac42a274677741b135736faa71b4cfa039c2ba8ba3630e621dea0502 SHA512 48bf58e9b6ce069a95eccf6086b3ed9531c7bb6993cfe90e04a86fa015bac21a7a8f0c77631fc29f05369fd5820a7e9712940ceb3d2250eefba99669cf69e770 WHIRLPOOL 535940093d26d775f77f2832f7cb1f4cdf7d13aaacc8580d85e4825f84498509f23ac14ca26acbd2c459228d4200f7fac29001b7fdbbfdeb551baf80b13c0179
+DIST patch-4.11-rc7.xz 6484760 SHA256 71b805ab591e4916b2638f41a93e07075e31ae1a206e0027171c2b64fb6b4b9c SHA512 01abe7a1d4cf5779479f4289734dd74ac202012e2b8058c2451cfa8b355a58ea2397c7f5c29bd5e3ba5a83cbc22bfc4738cd2b6f8caf4baa9e7495bc88340b6d WHIRLPOOL 1cc3293d7702cf2e1937551ec0df242c5824e992242b3ad5a54f130b7635f5425434b29cfbc1c81d3c853d18c62e0e2b84aadfd694ea0eaec6a8265888a70c4f
diff --git a/sys-kernel/git-sources/git-sources-4.11_rc7.ebuild b/sys-kernel/git-sources/git-sources-4.11_rc7.ebuild
new file mode 100644
index 000000000000..2a1ec252ced8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.11_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.10"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}