summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-10 08:49:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-10 13:00:42 +0200
commit605e2933fe2a39527dcb65194b576e12f88583a0 (patch)
treed109e7969afd7deba0ea00699fd1a720a42b787e /sys-kernel
parentvirtual/dist-kernel: Bump to 5.10.72 (diff)
downloadgentoo-605e2933fe2a39527dcb65194b576e12f88583a0.tar.gz
gentoo-605e2933fe2a39527dcb65194b576e12f88583a0.tar.bz2
gentoo-605e2933fe2a39527dcb65194b576e12f88583a0.zip
sys-kernel/vanilla-kernel: Bump to 5.4.152
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.4.152.ebuild108
2 files changed, 110 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index ca711ea56d35..21483ac0bb10 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -47,3 +47,5 @@ DIST linux-5.4.150.tar.sign 991 BLAKE2B 6292a8c6bc16f62201d95a170e5df7b1edd9f33e
DIST linux-5.4.150.tar.xz 109155076 BLAKE2B e34c474778d2ba1a619551fdb6c81be01ed0d155ab447bfcbe497c2258637b939fc1dda7d7161d8782e38d8c84e9fc94043d62a43698258594fdd6cfea8ac79b SHA512 5f6cc5852cb1e881027b8724920dd03b96f3ce2a58353ada6f7cf5bb0bffb3a8d4ded708f50963074ff41236e8c0aeaa7f81df0ac8e4f1147a7c4a0160c2c543
DIST linux-5.4.151.tar.sign 991 BLAKE2B 26cc28a8ea886acbd2bf16e23be6e5368958a91f2e3d403ce7a90f94c427ffc05a3edb670367f4f3934cca31b0213b85743f98554fda6b1a7b50577cad90b391 SHA512 95fded48c138d70f5c7df0828c23b2575fed66fb703128b61e8f59de282569aab7f45bae6f2ba9f1dec256a96cda987023246b53f42102ac339b418b63e67be6
DIST linux-5.4.151.tar.xz 109163992 BLAKE2B 12c2d24acab896ccf0d6edeea3d38fbfecda4621dddce4d5ef916b6face70a509cde8ae35ada5a65eb08c79afdbe4c84544a63e52c712d8d42682dd8559df296 SHA512 e210b9cdb47e5dc294688e23dffdd853bca96bdd613d6f476c291e1c949e185be2047735c69c01602c46d0bf767367975bf08b7b6976297b6a486529b0418982
+DIST linux-5.4.152.tar.sign 991 BLAKE2B 4ba252d2e4b245f6249dac83ca180ba48a3892262ebd5d721cd95e2ebbcae4b62fdfeb23d5cc7c15b0b52c9d6ad43839534a9fa2423d52c58a408cccb9efee2f SHA512 9aa21b4f04bbe79f06e5f44d4a6bb9a5e67946ceb6a0ae87693dd2ff4a2530e9d5f4d6fe051b8c62e28c49aba5a7cb984b44a427cc970d925cb762e3a611b821
+DIST linux-5.4.152.tar.xz 109160584 BLAKE2B 9fd0af5bb6319237471ca9dcfec8a5b8601dd4fc51e55ef9cfd956044ddafef0bfb017e2d19d277927c89b3dd1d1da09c10dfe88752b1032e5ffe81f331ce881 SHA512 183f70bb44ae2c8e0684b640fa733e9db5e0cf29e78bdd3156602cfc337f968ab308444f3671acff40ab674498d4879ded620c8f8c82a506f0d1512a24dace2b
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.152.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.152.ebuild
new file mode 100644
index 000000000000..dc33930084ad
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.152.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kernel-build verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.4.21
+CONFIG_HASH=2809b7faa6a8cb232cd825096c146b7bdc1e08ea
+GENTOO_CONFIG_VER=5.4.114
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI+=" https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/mgorny/gentoo-kernel-config/archive/v${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64.config
+ -> kernel-x86_64.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64.config
+ -> kernel-aarch64.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le.config
+ -> kernel-ppc64le.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686.config
+ -> kernel-i686.config.${CONFIG_VER}
+ )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ !sys-kernel/vanilla-kernel-bin:${SLOT}"
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( app-crypt/openpgp-keys-kernel )"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+pkg_pretend() {
+ ewarn "Starting with 5.4.52, Distribution Kernels are switching from Arch"
+ ewarn "Linux configs to Fedora. Please keep a backup kernel just in case."
+
+ kernel-install_pkg_pretend
+}
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64.config.${CONFIG_VER}" .config || die
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64.config.${CONFIG_VER}" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le.config.${CONFIG_VER}" .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ echo 'CONFIG_LOCALVERSION="-dist"' > "${T}"/version.config || die
+ local merge_configs=(
+ "${T}"/version.config
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/no-debug.config
+ )
+ [[ ${ARCH} == x86 ]] && merge_configs+=(
+ "${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"/32-bit.config
+ )
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}