summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 20:51:59 +0100
committerSam James <sam@gentoo.org>2022-04-07 20:51:59 +0100
commit256df48ff6e85ffa389cc2d25453d100279b62fe (patch)
tree8b916d4e3e8075ba42ce5849ba9ec3eeae9259cc /sys-libs
parentsys-fs/xfsprogs: add 5.15.0 (diff)
downloadgentoo-256df48ff6e85ffa389cc2d25453d100279b62fe.tar.gz
gentoo-256df48ff6e85ffa389cc2d25453d100279b62fe.tar.bz2
gentoo-256df48ff6e85ffa389cc2d25453d100279b62fe.zip
sys-libs/glibc: filter -fcf-protection
Set USE=cet if you want this. glibc can't be built with this *everywhere*, and the configure option (controlled by USE=cet) sets it for the components for which it works. It's just like SSP and PIE. You can't force it on all of glibc, and we have mechanisms to do it properly (USE=cet). Closes: https://bugs.gentoo.org/830454 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.34-r11.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.35-r2.ebuild3
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.34-r11.ebuild b/sys-libs/glibc/glibc-2.34-r11.ebuild
index ff5bd4304774..3cf633bea543 100644
--- a/sys-libs/glibc/glibc-2.34-r11.ebuild
+++ b/sys-libs/glibc/glibc-2.34-r11.ebuild
@@ -440,6 +440,9 @@ setup_flags() {
replace-flags -O0 -O1
filter-flags '-fstack-protector*'
+
+ # See end of bug #830454; we handle this via USE=cet
+ filter-flags '-fcf-protection='
}
use_multiarch() {
diff --git a/sys-libs/glibc/glibc-2.35-r2.ebuild b/sys-libs/glibc/glibc-2.35-r2.ebuild
index 6a0d35ce8ad5..22e2d5153f19 100644
--- a/sys-libs/glibc/glibc-2.35-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r2.ebuild
@@ -429,6 +429,9 @@ setup_flags() {
replace-flags -O0 -O1
filter-flags '-fstack-protector*'
+
+ # See end of bug #830454; we handle this via USE=cet
+ filter-flags '-fcf-protection='
}
use_multiarch() {
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2483aefe5d6a..94842d8172b7 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -430,6 +430,9 @@ setup_flags() {
replace-flags -O0 -O1
filter-flags '-fstack-protector*'
+
+ # See end of bug #830454; we handle this via USE=cet
+ filter-flags '-fcf-protection='
}
use_multiarch() {