summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/acpi_call
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/acpi_call')
-rw-r--r--sys-power/acpi_call/Manifest1
-rw-r--r--sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild37
-rw-r--r--sys-power/acpi_call/acpi_call-1.1.0.ebuild33
-rw-r--r--sys-power/acpi_call/acpi_call-9999.ebuild33
-rw-r--r--sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch26
-rw-r--r--sys-power/acpi_call/metadata.xml14
6 files changed, 144 insertions, 0 deletions
diff --git a/sys-power/acpi_call/Manifest b/sys-power/acpi_call/Manifest
new file mode 100644
index 000000000000..793682380e1f
--- /dev/null
+++ b/sys-power/acpi_call/Manifest
@@ -0,0 +1 @@
+DIST acpi_call-1.1.0.tar.gz 10470 SHA256 d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0 SHA512 d5cf13c15f9057e3a27aaacfee6dcdb17b6a79194bdc8fd57b8140c07a532e2e58151bea881aa158c1183ac3bbe89f83fcfc2279ffd9e945a72331b6ddbf2c70 WHIRLPOOL 9cfc9e8a9b21e712eb21ee2e708e9f1825f5ad19ddfc292e9b0c9e126b7841114f9e6bee2716bc58094a71a7cb231cdc70943cf33b2a5d8c15bd477af0abe849
diff --git a/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild b/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..1df9e2e8e561
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_prepare(){
+ epatch "${FILESDIR}/${P}-linux-3.17.patch"
+}
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/acpi_call-1.1.0.ebuild b/sys-power/acpi_call/acpi_call-1.1.0.ebuild
new file mode 100644
index 000000000000..a6e17ad2cf52
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/acpi_call-9999.ebuild b/sys-power/acpi_call/acpi_call-9999.ebuild
new file mode 100644
index 000000000000..a6e17ad2cf52
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch b/sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch
new file mode 100644
index 000000000000..32923a488aed
--- /dev/null
+++ b/sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch
@@ -0,0 +1,26 @@
+From c5b7a4bf93a28e6ce68beb54b48d3745db943e54 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <ottxor@gentoo.org>
+Date: Mon, 27 Oct 2014 21:57:10 -0600
+Subject: [PATCH] fix build with linux-3.17
+
+https://bugs.gentoo.org/show_bug.cgi?id=524614
+---
+ acpi_call.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/acpi_call.c b/acpi_call.c
+index 3025d97..fa4f2c6 100644
+--- a/acpi_call.c
++++ b/acpi_call.c
+@@ -6,7 +6,7 @@
+ #include <linux/proc_fs.h>
+ #include <linux/slab.h>
+ #include <asm/uaccess.h>
+-#include <acpi/acpi.h>
++#include <linux/acpi.h>
+
+ MODULE_LICENSE("GPL");
+
+--
+2.0.4
+
diff --git a/sys-power/acpi_call/metadata.xml b/sys-power/acpi_call/metadata.xml
new file mode 100644
index 000000000000..e555b0bb58b5
--- /dev/null
+++ b/sys-power/acpi_call/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mkottman/acpi_call</remote-id>
+ </upstream>
+</pkgmetadata>