summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-11-03 11:15:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-11-03 11:23:13 +0200
commitbe1e3a43d0c24b8a839eb947ecf2cce780e09c4a (patch)
tree2e9a5002a72fb214ea798fd73a638ceef54d47b8 /sys-process/uksmd/uksmd-0_pre20211019.ebuild
parentdev-python/libpillowfight: add 0.3.0_p20210816, enable tests (diff)
downloadgentoo-be1e3a43d0c24b8a839eb947ecf2cce780e09c4a.tar.gz
gentoo-be1e3a43d0c24b8a839eb947ecf2cce780e09c4a.tar.bz2
gentoo-be1e3a43d0c24b8a839eb947ecf2cce780e09c4a.zip
sys-process/uksmd: add 2021-10-19 snapshot
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-process/uksmd/uksmd-0_pre20211019.ebuild')
-rw-r--r--sys-process/uksmd/uksmd-0_pre20211019.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-process/uksmd/uksmd-0_pre20211019.ebuild b/sys-process/uksmd/uksmd-0_pre20211019.ebuild
new file mode 100644
index 000000000000..bbc2fd9e6bf8
--- /dev/null
+++ b/sys-process/uksmd/uksmd-0_pre20211019.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="e1d4b12d22fd710f0155d75585940f0d439f1544"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/libcap-ng
+ sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/uksmd-0_pre20200504-respect-cflags-ldflags.patch" )
+
+src_install() {
+ default
+ einstalldocs
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+ systemd_dounit distro/uksmd.service
+}