summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-02 06:53:20 +0000
committerSam James <sam@gentoo.org>2024-01-02 06:53:30 +0000
commita2bae182478995e86066abf6e2b9d66073f19304 (patch)
tree148b2b92e57e5efeaef869a0c17919cf9791af6c /sys-process
parentsys-apps/moar: add 1.20.0 (diff)
downloadgentoo-a2bae182478995e86066abf6e2b9d66073f19304.tar.gz
gentoo-a2bae182478995e86066abf6e2b9d66073f19304.tar.bz2
gentoo-a2bae182478995e86066abf6e2b9d66073f19304.zip
sys-process/parallel: add 20231222
Closes: https://bugs.gentoo.org/857954 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/parallel-20231222.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index 15fb8aa88fce..511b8c2fac48 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -2,3 +2,5 @@ DIST parallel-20230922.tar.bz2 2507914 BLAKE2B 88053502e8c663d795f0752b4b13d1440
DIST parallel-20230922.tar.bz2.sig 2080 BLAKE2B 460121de26a73e2880a2614b37b49b598628960e001a7e65b1157df557552b4f14617dc8f109505147e81dfcb824bc602a5a8e46b0e76b0a9b93b6a4f3640e5a SHA512 5024d4097822bdc7322a91dbf024dfc93a780002795885ae45c26f109917d748e4203ab5e27a6e18914c7cfa7e8b4c8dcf2ed945f4bed529c85ded2a2ad4693a
DIST parallel-20231122.tar.bz2 2526069 BLAKE2B 5ddd4428c795ff51d2b1866438d72d626fd96deb3d73bc78b4e98d986c003274d4a0ce878cb1943b4d6bbf33531c332e39668b03e3cc458660adbaac2c8f4ef4 SHA512 4111c1f4b9257d7a954791b9c22c9edee576bedcc03cac9fc5d52ed50370abbe52b16518fa1d8b8af6741dd4426aec5f09f4b2ed96518f5ffbe75c56147752df
DIST parallel-20231122.tar.bz2.sig 2080 BLAKE2B 5a343abf5d057d9357a7e64660c0c4a055e234dbc27b5f26cd9d9f537f7b454613b15859c5cbf385ce3f0343b481473ed4af24c166c3e6de9eeee6b4a05aa1e9 SHA512 d2a25be9346b546a078faf819d7d5d8487ad570ed8231a1cc285b2a4893d82c74ece4d8c2a788e5900ff25c72e63018213c1003fd2fbe015ead7e32a63f3b224
+DIST parallel-20231222.tar.bz2 2541114 BLAKE2B 677b36c2562908f89d4eaae483555a840ea41e9359c77a17fa1dde2871c17a520ae8b948d9fedb1d67d220b7795df9bcc080d3bff67a9b126ff1ea2c329cdb15 SHA512 18d3dd5a7aab4cbf7f9ea8c5d8c8a2dd6b2bd5c9deb56daba85a3ff1c3b3ea84403913d7266b7ea04c0dec432d1288f98c911ac29120d775ee795c56cc31c0a2
+DIST parallel-20231222.tar.bz2.sig 2080 BLAKE2B d883d6ccb64c89f2eacb1760321ef40c60ca09868499e5b99db211b45bb6f43747c1999eb99e8665897abcb978d25ad4e28c35f09dfea9bc92a0ab3d9d4d7981 SHA512 ae790463207701ace9771c02c9080875465a3215b5b471ddd4f095e593c8ebb9966f7330ec8b069a9617a4b4ba0b856b473b874c4cb36e2cee325ad9210921ac
diff --git a/sys-process/parallel/parallel-20231222.ebuild b/sys-process/parallel/parallel-20231222.ebuild
new file mode 100644
index 000000000000..fd04358e548a
--- /dev/null
+++ b/sys-process/parallel/parallel-20231222.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/oletange.asc
+inherit verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-oletange-20210423 )"
+
+src_configure() {
+ # bug #908214
+ unset PARALLEL_HOME
+
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_compile() {
+ # Silence a warning where it tries to use pod2pdf; force it to fallback
+ # to pre-generated PDF.
+ mkdir "${T}"/fake || die
+ ln -s "${BROOT}"/bin/false "${T}"/fake/pod2pdf || die
+ export PATH="${T}/fake:${PATH}"
+
+ default
+}