summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-30 16:10:01 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-30 19:05:30 +0100
commit32a430d6f3c1cf269dd0582e08074513549121e2 (patch)
tree8c3b1325d789e3b03c7f6011e83a47ad6670ef32 /virtual/python-cffi/python-cffi-0.ebuild
parentdev-python/cryptography: Enable pypy3 (diff)
downloadgentoo-32a430d6f3c1cf269dd0582e08074513549121e2.tar.gz
gentoo-32a430d6f3c1cf269dd0582e08074513549121e2.tar.bz2
gentoo-32a430d6f3c1cf269dd0582e08074513549121e2.zip
virtual/python-cffi: Introduce a virtual for cffi package
Diffstat (limited to 'virtual/python-cffi/python-cffi-0.ebuild')
-rw-r--r--virtual/python-cffi/python-cffi-0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/virtual/python-cffi/python-cffi-0.ebuild b/virtual/python-cffi/python-cffi-0.ebuild
new file mode 100644
index 000000000000..d5af52c57744
--- /dev/null
+++ b/virtual/python-cffi/python-cffi-0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python cffi package"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# built-in in PyPy and PyPy3
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')"