summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:17:06 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:17:06 -0400
commit0134090a488121a50a6cf57a87a62de4e0efe1a3 (patch)
tree8d4da51657e3cd3fa638671025953f03d2bf65f6 /virtual
parentdev-python/pathlib: remove pypy3 from PYTHON_COMPAT (diff)
downloadgentoo-0134090a488121a50a6cf57a87a62de4e0efe1a3.tar.gz
gentoo-0134090a488121a50a6cf57a87a62de4e0efe1a3.tar.bz2
gentoo-0134090a488121a50a6cf57a87a62de4e0efe1a3.zip
virtual/python-pathlib: remove pypy3 requirement
Bug: https://bugs.gentoo.org/616596 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-pathlib/python-pathlib-1.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/virtual/python-pathlib/python-pathlib-1.0.ebuild b/virtual/python-pathlib/python-pathlib-1.0.ebuild
index 10122a0b2869..5c3ea9070d5d 100644
--- a/virtual/python-pathlib/python-pathlib-1.0.ebuild
+++ b/virtual/python-pathlib/python-pathlib-1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
inherit python-r1
@@ -14,4 +14,4 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-python/pathlib[${PYTHON_USEDEP}]' \
- python{2_7,3_3} pypy pypy3)"
+ python2_7 pypy)"