summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-13 09:52:59 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-13 10:18:10 +0100
commit30e4408a12e751b806833233846938b91e68cf79 (patch)
treebc3f18274ddbb76f7dc6b7f373cd03389022d2c6 /www-apps/cgp
parentdev-lang/rust: bump to 1.27.1 (diff)
downloadgentoo-30e4408a12e751b806833233846938b91e68cf79.tar.gz
gentoo-30e4408a12e751b806833233846938b91e68cf79.tar.bz2
gentoo-30e4408a12e751b806833233846938b91e68cf79.zip
www-apps/cgp: bump to version p20180620
Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9209
Diffstat (limited to 'www-apps/cgp')
-rw-r--r--www-apps/cgp/Manifest1
-rw-r--r--www-apps/cgp/cgp-1_p20180620.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/www-apps/cgp/Manifest b/www-apps/cgp/Manifest
index 7fddb0cd05da..9d92f0821556 100644
--- a/www-apps/cgp/Manifest
+++ b/www-apps/cgp/Manifest
@@ -1 +1,2 @@
DIST cgp-1.tar.gz 139265 BLAKE2B bf0f18def8ac3c2117b951172d4150f0626e8dcbe22accbcc6ad156e5f9f5c21792e38fa1bf5a964d8b50cbc7ee9003e4dcdcd75730ba2b0445f4dcfeffdda6c SHA512 fc5bc6d39dac896b56579cb6ca013c81493b994a7a190e0c0eec8a64f7b87c6eb2e0ad5cc969b8ea03ca4b00eee212ccee5c8785c23f5656bff3fe5490ff8f75
+DIST cgp-1_p20180620.tar.gz 139549 BLAKE2B 2cc1a416ae1158b5788615b05bf43039049af52eb5296e7fd8136c9895e8ee0a9887e84ad37c6598a4c4387982a2860fbdb7cf9cdff39cfe5bbee598b9ace88f SHA512 acd09bb699af678347dacfc08fee60a86843874543851805f245952e538777d7ccd528c156f7a21b803503c7aac134013a4eb8200d5266cf35541b0dce5839e4
diff --git a/www-apps/cgp/cgp-1_p20180620.ebuild b/www-apps/cgp/cgp-1_p20180620.ebuild
new file mode 100644
index 000000000000..6051624a6a90
--- /dev/null
+++ b/www-apps/cgp/cgp-1_p20180620.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN="${PN^^}"
+MY_PV="1920ca24a067ac157a6bd8f3c017f4c6244ae245"
+
+DESCRIPTION="A graphical web-based front-end for visualizing RRD collected by collectd"
+HOMEPAGE="https://github.com/pommi/CGP
+ https://pommi.nethuis.nl/category/cgp/"
+SRC_URI="https://github.com/pommi/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-2.0 GPL-2+ GPL-3 MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/php[json]
+ net-analyzer/rrdtool[graph]
+ virtual/httpd-php"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+DOCS=( "README.md" "doc/CHANGELOG" "doc/nginx.conf" )
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ # Since the docs are already installed, remove them from htdocs
+ # The file doc/CHANGELOG is needed, as CGP reads from there it's version
+ rm -r .gitignore doc/LICENSE doc/nginx.conf || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ einfo "The command shell_exec must not be disabled"
+ einfo "through the disable_functions php.ini directive."
+ einfo "It must allow execution of the rrdtool program."
+ einfo ""
+ einfo "An configuration file for www-servers/nginx"
+ einfo "has been installed as an example."
+}