summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2025-01-07 08:59:31 -0500
committerCraig Andrews <candrews@gentoo.org>2025-01-07 09:00:45 -0500
commitc785cf571908190366ea9cee5d25c13f349f30a9 (patch)
treec35e5f6c5e911891131a8672c40885c01be53216 /www-apps/sonarr-bin/sonarr-bin-4.0.12.2825.ebuild
parentwww-apps/readarr-bin: drop 0.4.6.2711 (diff)
downloadgentoo-c785cf571908190366ea9cee5d25c13f349f30a9.tar.gz
gentoo-c785cf571908190366ea9cee5d25c13f349f30a9.tar.bz2
gentoo-c785cf571908190366ea9cee5d25c13f349f30a9.zip
www-apps/sonarr-bin: add 4.0.12.2825
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apps/sonarr-bin/sonarr-bin-4.0.12.2825.ebuild')
-rw-r--r--www-apps/sonarr-bin/sonarr-bin-4.0.12.2825.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/www-apps/sonarr-bin/sonarr-bin-4.0.12.2825.ebuild b/www-apps/sonarr-bin/sonarr-bin-4.0.12.2825.ebuild
new file mode 100644
index 000000000000..26a3f8494331
--- /dev/null
+++ b/www-apps/sonarr-bin/sonarr-bin-4.0.12.2825.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Sonarr is a Smart PVR for newsgroup and bittorrent users"
+HOMEPAGE="https://www.sonarr.tv"
+
+SRC_URI="
+ amd64? (
+ elibc_glibc? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-x64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-x64.tar.gz
+ )
+ )
+ arm? (
+ elibc_glibc? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm.tar.gz
+ )
+ )
+ arm64? (
+ elibc_glibc? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-arm64.tar.gz
+ )
+ elibc_musl? (
+ https://github.com/Sonarr/Sonarr/releases/download/v${PV}/Sonarr.develop.${PV}.linux-musl-arm64.tar.gz
+ )
+ )
+"
+S="${WORKDIR}/Sonarr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist strip test"
+
+RDEPEND="
+ acct-group/sonarr
+ acct-user/sonarr
+ media-video/mediainfo
+ dev-libs/icu
+ dev-util/lttng-ust:0
+ dev-db/sqlite
+"
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ default
+
+ # https://github.com/dotnet/runtime/issues/57784
+ rm libcoreclrtraceptprovider.so Sonarr.Update/libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}/sonarr.init-r2" sonarr
+
+ keepdir /var/lib/sonarr
+ fowners -R sonarr:sonarr /var/lib/sonarr
+
+ insinto /etc/logrotate.d
+ insopts -m0644 -o root -g root
+ newins "${FILESDIR}/sonarr.logrotate" sonarr
+
+ dodir "/opt/sonarr"
+ cp -R "${S}/." "${D}/opt/sonarr" || die "Install failed!"
+
+ systemd_newunit "${FILESDIR}/sonarr.service-r1" "sonarr.service"
+ systemd_newunit "${FILESDIR}/sonarr.service-r1" "sonarr@.service"
+}