summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 11:34:43 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:39:44 +0200
commit5ddaa9004954ea8c00a9f044241fe3dec8a9e9cf (patch)
tree0aaa9f06f40279df2f867c14782f7c2490869c86 /www-client/epiphany
parentwww-client/epiphany: Drop old (diff)
downloadgentoo-5ddaa9004954ea8c00a9f044241fe3dec8a9e9cf.tar.gz
gentoo-5ddaa9004954ea8c00a9f044241fe3dec8a9e9cf.tar.bz2
gentoo-5ddaa9004954ea8c00a9f044241fe3dec8a9e9cf.zip
www-client/epiphany: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.18.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index a8aebeae8e2b..93dfaf57be5d 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-3.18.4.tar.xz 3054500 SHA256 be699d484371111abae754e669187215df73e21533f461e513b79537d7a1c1c1 SHA512 b23fe348d4ef18b4f4227352216ed377d741897dbc44221da83a0a7a1395a5aca6ca89066112f664c7724b5ad1a58c9dab1e415ab408176a33fc9cbd9bd12be7 WHIRLPOOL dae50483ed1889abcbc62b96f338711ac2f9b8cd5f13b370725df015acec2b278013b122dd5dfc1e99101868c5bc94b040812a28e878f44160ed59ec53da4a46
+DIST epiphany-3.18.5.tar.xz 3056960 SHA256 a27e9175a63b4167865ec0554217dee412e29eed404bdeec2011158b2a3b1c4e SHA512 9ea1a722a279af83e743929bb87c5720a01a6e584186aab83e5244d4af9583ee88bea1b0ce932642b0d6ca6135fef61428de5f31a41602a49df38b0ca9a84d61 WHIRLPOOL 6dcf92fa4b91ba4a2da86a16ad031e253aeefc979cca2b0f378b3532ea3f52473857e2dacec0cc445879c5c6462f02d41f29f7a95941f1307d9563a6c378c295
diff --git a/www-client/epiphany/epiphany-3.18.5.ebuild b/www-client/epiphany/epiphany-3.18.5.ebuild
new file mode 100644
index 000000000000..f3982ca085d4
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.18.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nss test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5:=
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.9.5:4
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix unittests
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}