summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:18:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:14 +0100
commita114d7cd8ea451b83f111a86fc4a648985bdb01d (patch)
tree28603817791ee6e8b7129ff794f0822fa17ef72e /www-client/firefox
parentMove {sys-libs → llvm-runtimes}/libcxx (diff)
downloadgentoo-a114d7cd8ea451b83f111a86fc4a648985bdb01d.tar.gz
gentoo-a114d7cd8ea451b83f111a86fc4a648985bdb01d.tar.bz2
gentoo-a114d7cd8ea451b83f111a86fc4a648985bdb01d.zip
Move {sys-libs → llvm-runtimes}/compiler-rt-sanitizers
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-128.5.0.ebuild6
-rw-r--r--www-client/firefox/firefox-128.5.1.ebuild6
-rw-r--r--www-client/firefox/firefox-133.0.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/www-client/firefox/firefox-128.5.0.ebuild b/www-client/firefox/firefox-128.5.0.ebuild
index 497f5a20e4f7..bfa527287093 100644
--- a/www-client/firefox/firefox-128.5.0.ebuild
+++ b/www-client/firefox/firefox-128.5.0.ebuild
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:${LLVM_SLOT}
clang? (
sys-devel/lld:${LLVM_SLOT}
- pgo? ( sys-libs/compiler-rt-sanitizers:${LLVM_SLOT}[profile] )
+ pgo? ( llvm-runtimes/compiler-rt-sanitizers:${LLVM_SLOT}[profile] )
)
wasm? ( sys-devel/lld:${LLVM_SLOT} )
')
@@ -233,8 +233,8 @@ llvm_check_deps() {
fi
if use pgo ; then
- if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
- einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!" >&2
+ if ! has_version -b "=llvm-runtimes/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
+ einfo "=llvm-runtimes/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!" >&2
einfo "Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
diff --git a/www-client/firefox/firefox-128.5.1.ebuild b/www-client/firefox/firefox-128.5.1.ebuild
index c2f3c8c3463e..b2e808d0894a 100644
--- a/www-client/firefox/firefox-128.5.1.ebuild
+++ b/www-client/firefox/firefox-128.5.1.ebuild
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:${LLVM_SLOT}
clang? (
sys-devel/lld:${LLVM_SLOT}
- pgo? ( sys-libs/compiler-rt-sanitizers:${LLVM_SLOT}[profile] )
+ pgo? ( llvm-runtimes/compiler-rt-sanitizers:${LLVM_SLOT}[profile] )
)
wasm? ( sys-devel/lld:${LLVM_SLOT} )
')
@@ -233,8 +233,8 @@ llvm_check_deps() {
fi
if use pgo ; then
- if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
- einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!" >&2
+ if ! has_version -b "=llvm-runtimes/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
+ einfo "=llvm-runtimes/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!" >&2
einfo "Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
diff --git a/www-client/firefox/firefox-133.0.ebuild b/www-client/firefox/firefox-133.0.ebuild
index 528b17e744fa..33f43c19be0b 100644
--- a/www-client/firefox/firefox-133.0.ebuild
+++ b/www-client/firefox/firefox-133.0.ebuild
@@ -99,7 +99,7 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/llvm:${LLVM_SLOT}
clang? (
sys-devel/lld:${LLVM_SLOT}
- pgo? ( sys-libs/compiler-rt-sanitizers:${LLVM_SLOT}[profile] )
+ pgo? ( llvm-runtimes/compiler-rt-sanitizers:${LLVM_SLOT}[profile] )
)
wasm? ( sys-devel/lld:${LLVM_SLOT} )
')
@@ -237,8 +237,8 @@ llvm_check_deps() {
fi
if use pgo ; then
- if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
- einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!" >&2
+ if ! has_version -b "=llvm-runtimes/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
+ einfo "=llvm-runtimes/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!" >&2
einfo "Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi