summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2022-02-10 20:56:08 +0100
committerStephan Hartmann <sultan@gentoo.org>2022-02-10 20:56:48 +0100
commit296ad751bf58d50dfe68af93356ac6787e690512 (patch)
tree520ab5784852de4db83d3baa0f966d50cc168cbb /www-client
parentdev-db/pgcli: add 3.3.1 (diff)
downloadgentoo-296ad751bf58d50dfe68af93356ac6787e690512.tar.gz
gentoo-296ad751bf58d50dfe68af93356ac6787e690512.tar.bz2
gentoo-296ad751bf58d50dfe68af93356ac6787e690512.zip
www-client/microsoft-edge: automated bump (98.0.1108.50)
Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/microsoft-edge/Manifest1
-rw-r--r--www-client/microsoft-edge/microsoft-edge-98.0.1108.50.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/www-client/microsoft-edge/Manifest b/www-client/microsoft-edge/Manifest
index 2398d179ab3e..49e3f8f5fbc3 100644
--- a/www-client/microsoft-edge/Manifest
+++ b/www-client/microsoft-edge/Manifest
@@ -1 +1,2 @@
DIST microsoft-edge-stable_98.0.1108.43-1_amd64.deb 124175258 BLAKE2B 34fdd3d3aed914d00909864cbdb49107f93a7e0e9b25f5d061d07b25895a2c6ae8f885bf084b9927d89b898aec67f94f6ecc402df50d4e5616eb89a37d11761f SHA512 7b4ea49f9526ad5053c3e235819d26dc4b04f63787bf90b230b125f6f6a19a19c0e954e15ed372d68e3b29015fe3d8cf25861e8b1935540506b24a6b87dd325f
+DIST microsoft-edge-stable_98.0.1108.50-1_amd64.deb 124182902 BLAKE2B 5eb7b8b8adab26628f49b54433e563e7152579f133ee50686a8176fb20a6550236d7264a9e284303cd1d9d7973bb7e6871bfee2c8e1861de7b6e34ef60070aa2 SHA512 1e9fb67f3f3dd08770c850553fa75fcf372afeeb2e7bcc324c9f9f9d467122ac79583c93501d5e8e0339b9d44d7e6e3cb98c56a40a6364b3470de3ea98b0b2be
diff --git a/www-client/microsoft-edge/microsoft-edge-98.0.1108.50.ebuild b/www-client/microsoft-edge/microsoft-edge-98.0.1108.50.ebuild
new file mode 100644
index 000000000000..a8cc7e730ebf
--- /dev/null
+++ b/www-client/microsoft-edge/microsoft-edge-98.0.1108.50.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit chromium-2 desktop pax-utils unpacker xdg
+
+DESCRIPTION="The web browser from Microsoft"
+HOMEPAGE="https://www.microsoft.com/en-us/edge"
+
+if [[ ${PN} == microsoft-edge ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://packages.microsoft.com/repos/edge/pool/main/m/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="microsoft-edge"
+SLOT="0"
+RESTRICT="bindist mirror strip"
+IUSE="+mip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-misc/ca-certificates
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/liberation-fonts
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl[ssl]
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/pango
+ x11-misc/xdg-utils
+ mip? ( app-crypt/libsecret )
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/microsoft-edge.*\\.desktop"
+S=${WORKDIR}
+EDGE_HOME="opt/microsoft/msedge${PN#microsoft-edge}"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for microsoft-edge fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "microsoft-edge only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm _gpgorigin || die
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ gzip -d usr/share/man/man1/${MY_PN}.1.gz || die
+ if [[ -L usr/share/man/man1/${PN}.1.gz ]]; then
+ rm usr/share/man/man1/${PN}.1.gz || die
+ dosym ${MY_PN}.1 usr/share/man/man1/${PN}.1
+ fi
+
+ local suffix=
+ [[ ${PN} == microsoft-edge-beta ]] && suffix=_beta
+ [[ ${PN} == microsoft-edge-dev ]] && suffix=_dev
+
+ local size
+ for size in 16 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${EDGE_HOME}/product_logo_${size}${suffix}.png" ${PN}.png
+ done
+
+ if ! use mip; then
+ rm "${EDGE_HOME}"/libmip_{core,protection_sdk}.so || die
+ fi
+
+ pax-mark m "${EDGE_HOME}/msedge"
+}