summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-08 21:19:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-08 21:20:57 +0200
commit32728668bf3e609dab53f4fb5c1b1cf004db32ff (patch)
tree902cbbb9640ad7d1e601c285b5fe0c05f1c80db8 /www-client
parentdev-lang/spidermonkey: check for sys-devel/llvm:$LLVM_SLOT in llvm_check_deps() (diff)
downloadgentoo-32728668bf3e609dab53f4fb5c1b1cf004db32ff.tar.gz
gentoo-32728668bf3e609dab53f4fb5c1b1cf004db32ff.tar.bz2
gentoo-32728668bf3e609dab53f4fb5c1b1cf004db32ff.zip
www-client/firefox: check for sys-devel/llvm:$LLVM_SLOT in llvm_check_deps()
When we override llvm_check_deps(), we have to check for sys-devel/llvm:$LLVM_SLOT on our own. Bug: https://bugs.gentoo.org/788763 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-78.10.1.ebuild5
-rw-r--r--www-client/firefox/firefox-88.0.1.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-78.10.1.ebuild b/www-client/firefox/firefox-78.10.1.ebuild
index c2e05bd89ee6..94c0a2be1af8 100644
--- a/www-client/firefox/firefox-78.10.1.ebuild
+++ b/www-client/firefox/firefox-78.10.1.ebuild
@@ -200,6 +200,11 @@ if [[ -z "${MOZ_GMP_PLUGIN_LIST+set}" ]] ; then
fi
llvm_check_deps() {
+ if ! has_version -b "sys-devel/llvm:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/llvm:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
diff --git a/www-client/firefox/firefox-88.0.1.ebuild b/www-client/firefox/firefox-88.0.1.ebuild
index 9f488363331d..64ae6e7f68e7 100644
--- a/www-client/firefox/firefox-88.0.1.ebuild
+++ b/www-client/firefox/firefox-88.0.1.ebuild
@@ -193,6 +193,11 @@ if [[ -z "${MOZ_GMP_PLUGIN_LIST+set}" ]] ; then
fi
llvm_check_deps() {
+ if ! has_version -b "sys-devel/llvm:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/llvm:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1