summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-12-20 15:06:38 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-12-20 15:25:40 +0100
commit4b698916b7fd96b222f9b4e80fb0312fec510479 (patch)
tree70be53eb4c8ea14b8ffea30b688de8e54b0a4f13 /www-servers/uwsgi
parentwww-servers/gunicorn: Remove dev-python/gevent optfeature (diff)
downloadgentoo-4b698916b7fd96b222f9b4e80fb0312fec510479.tar.gz
gentoo-4b698916b7fd96b222f9b4e80fb0312fec510479.tar.bz2
gentoo-4b698916b7fd96b222f9b4e80fb0312fec510479.zip
www-servers/uwsgi: Remove USE=python-gevent
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'www-servers/uwsgi')
-rw-r--r--www-servers/uwsgi/metadata.xml1
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.19.1-r109.ebuild12
2 files changed, 2 insertions, 11 deletions
diff --git a/www-servers/uwsgi/metadata.xml b/www-servers/uwsgi/metadata.xml
index d90f0ad8dfee..84453cdb8a75 100644
--- a/www-servers/uwsgi/metadata.xml
+++ b/www-servers/uwsgi/metadata.xml
@@ -9,7 +9,6 @@
<flag name="go">Build the gccgo plugin to run Go applications.</flag>
<flag name="json">Support json as a configuration file format.</flag>
<flag name="python-asyncio">Use the EXPERIMENTAL asyncio (tulip) for python3.4 async request dispatching and as LoopEngine (see http://uwsgi-docs.readthedocs.org/en/latest/asyncio.html).</flag>
- <flag name="python-gevent">Use <pkg>dev-python/gevent</pkg> for async request dispatching and as LoopEngine (see http://projects.unbit.it/uwsgi/wiki/Gevent).</flag>
<flag name="routing">Enable routing support</flag>
<flag name="yaml">Support yaml as a configuration file format.</flag>
<flag name="yajl">Use <pkg>dev-libs/yajl</pkg> instead of <pkg>dev-libs/jansson</pkg> for parsing JSON configuration files (if USe=json is set)</flag>
diff --git a/www-servers/uwsgi/uwsgi-2.0.19.1-r109.ebuild b/www-servers/uwsgi/uwsgi-2.0.19.1-r109.ebuild
index 35d80ed88c4b..f7ef10e2833d 100644
--- a/www-servers/uwsgi/uwsgi-2.0.19.1-r109.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.19.1-r109.ebuild
@@ -43,7 +43,7 @@ UWSGI_PLUGINS_OPT=( alarm_{curl,xmpp} clock_{monotonic,realtime} curl_cron
systemd_logger transformation_toupper tuntap webdav xattr xslt zabbix )
LANG_SUPPORT_SIMPLE=( cgi mono perl ) # plugins which can be built in the main build process
-LANG_SUPPORT_EXTENDED=( go lua php python python-asyncio python-gevent ruby )
+LANG_SUPPORT_EXTENDED=( go lua php python python-asyncio ruby )
# plugins to be ignored (for now):
# cheaper_backlog2: example plugin
@@ -71,7 +71,6 @@ REQUIRED_USE="|| ( ${LANG_SUPPORT_SIMPLE[@]} ${LANG_SUPPORT_EXTENDED[@]} )
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
python-asyncio? ( python )
- python-gevent? ( python )
expat? ( xml )"
# util-linux is required for libuuid when requesting zeromq support
@@ -120,7 +119,6 @@ CDEPEND="
)
python? ( ${PYTHON_DEPS} )
python-asyncio? ( virtual/python-greenlet[${PYTHON_USEDEP}] )
- python-gevent? ( >=dev-python/gevent-1.3.5[${PYTHON_USEDEP}] )
ruby? ( $(ruby_implementations_depend) )"
DEPEND="${CDEPEND}"
RDEPEND="${CDEPEND}
@@ -256,11 +254,8 @@ python_compile_plugins() {
fi
fi
- if use python-gevent ; then
- ${PYTHON} uwsgiconfig.py --plugin plugins/gevent gentoo gevent${PYV} || die "building plugin for gevent-support in ${EPYTHON} failed"
- fi
- if use python-gevent || use python-asyncio; then
+ if use python-asyncio; then
${PYTHON} uwsgiconfig.py --plugin plugins/greenlet gentoo greenlet${PYV} || die "building plugin for greenlet-support in ${EPYTHON} failed"
fi
}
@@ -365,9 +360,6 @@ pkg_postinst() {
elog " (asyncio is only supported in python3.4)"
fi
fi
- if use python-gevent ; then
- elog " '--plugins ${EPYV},gevent${PYV}' for gevent support in ${EPYTHON}"
- fi
}
use python && python_foreach_impl python_pkg_postinst