summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-17 14:48:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-17 14:48:57 +0100
commitb1aab531b7d01d77999a7ad1d209e0357f7bbcf4 (patch)
tree16cb4b14c4b8716ce8ea5162a78394081b97d046 /x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.2.0.ebuild
parentnet-analyzer/wireshark: x86 stable wrt bug #600086 (diff)
downloadgentoo-b1aab531b7d01d77999a7ad1d209e0357f7bbcf4.tar.gz
gentoo-b1aab531b7d01d77999a7ad1d209e0357f7bbcf4.tar.bz2
gentoo-b1aab531b7d01d77999a7ad1d209e0357f7bbcf4.zip
x11-drivers/xf86-video-amdgpu: Bump to version 1.2.0 (bug #600100).
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.2.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.2.0.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.2.0.ebuild
new file mode 100644
index 000000000000..95627753c9c1
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_DRI="always"
+inherit xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ XORG_EAUTORECONF=yes
+ SRC_URI=""
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+IUSE="glamor"
+
+RDEPEND="x11-libs/libdrm[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable glamor)"
+ xorg-2_src_configure
+}