summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-29 09:59:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-29 09:59:37 +0100
commita691ff58f141b95596de85abad71471e8a427da8 (patch)
tree46f4db7760599ce3edeef99a5e8c10527f507833 /x11-libs
parentdev-ruby/rubygems: add 3.2.7 (diff)
downloadgentoo-a691ff58f141b95596de85abad71471e8a427da8.tar.gz
gentoo-a691ff58f141b95596de85abad71471e8a427da8.tar.bz2
gentoo-a691ff58f141b95596de85abad71471e8a427da8.zip
x11-libs/libva: Use upstream fix for USE="wayland" build
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libva/files/libva-2.10.0-fix_wayland_build.patch29
-rw-r--r--x11-libs/libva/files/libva-2.10.0-unbreak_gnu_sed.patch31
-rw-r--r--x11-libs/libva/libva-2.10.0.ebuild2
3 files changed, 30 insertions, 32 deletions
diff --git a/x11-libs/libva/files/libva-2.10.0-fix_wayland_build.patch b/x11-libs/libva/files/libva-2.10.0-fix_wayland_build.patch
new file mode 100644
index 000000000000..cf799cd3d686
--- /dev/null
+++ b/x11-libs/libva/files/libva-2.10.0-fix_wayland_build.patch
@@ -0,0 +1,29 @@
+From 3a71a012b72480ffdf1e2361845036f3cc9d7154 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Sat, 9 Jan 2021 13:17:38 +0000
+Subject: [PATCH] autotools: use shell grouping instead of sed to prepend a
+ line
+
+dash and pdksh don't support $'...'
+
+/bin/sed: -e expression #1, char 2: unknown command: `1'
+---
+ va/wayland/Makefile.am | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/va/wayland/Makefile.am b/va/wayland/Makefile.am
+index f48afb4d..40a54616 100644
+--- a/va/wayland/Makefile.am
++++ b/va/wayland/Makefile.am
+@@ -70,8 +70,9 @@ va_wayland_drm.c: $(protocol_source_h)
+ %-client-protocol-export.c : %.xml
+ $(AM_V_GEN)$(WAYLAND_SCANNER) code < $< > $@
+ %-client-protocol.c: %-client-protocol-export.c
+- $(AM_V_GEN)$(SED) -e $$'1i\\\n#include "sysdeps.h"\n' \
+- -e 's@WL_EXPORT@DLL_HIDDEN@g' < $< > $@
++ $(AM_V_GEN){ echo '#include "sysdeps.h"'; $(SED) \
++ -e 's@WL_EXPORT@DLL_HIDDEN@g' \
++ < $<; } > $@
+
+ EXTRA_DIST = \
+ wayland-drm.xml \
diff --git a/x11-libs/libva/files/libva-2.10.0-unbreak_gnu_sed.patch b/x11-libs/libva/files/libva-2.10.0-unbreak_gnu_sed.patch
deleted file mode 100644
index 411c6c475589..000000000000
--- a/x11-libs/libva/files/libva-2.10.0-unbreak_gnu_sed.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 508cf475854c83b61a63d4c5f143b9a405fef77c Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Sat, 9 Jan 2021 01:21:55 +0100
-Subject: [PATCH] Revert "autotools: unbreak --enable-wayland with BSD sed"
-
-This reverts commit 78431a361bed0b6e9f1f3ebc0de8897b069b3848
-as it breaks GNU sed
-
-https://github.com/intel/libva/issues/489
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- va/wayland/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/va/wayland/Makefile.am b/va/wayland/Makefile.am
-index f48afb4..705efa3 100644
---- a/va/wayland/Makefile.am
-+++ b/va/wayland/Makefile.am
-@@ -70,7 +70,7 @@ va_wayland_drm.c: $(protocol_source_h)
- %-client-protocol-export.c : %.xml
- $(AM_V_GEN)$(WAYLAND_SCANNER) code < $< > $@
- %-client-protocol.c: %-client-protocol-export.c
-- $(AM_V_GEN)$(SED) -e $$'1i\\\n#include "sysdeps.h"\n' \
-+ $(AM_V_GEN)$(SED) -e '1i#include "sysdeps.h"' \
- -e 's@WL_EXPORT@DLL_HIDDEN@g' < $< > $@
-
- EXTRA_DIST = \
---
-2.30.0
-
diff --git a/x11-libs/libva/libva-2.10.0.ebuild b/x11-libs/libva/libva-2.10.0.ebuild
index 8f6274df2517..6dbd26cce39f 100644
--- a/x11-libs/libva/libva-2.10.0.ebuild
+++ b/x11-libs/libva/libva-2.10.0.ebuild
@@ -62,7 +62,7 @@ MULTILIB_WRAPPED_HEADERS=(
)
PATCHES=(
- "${FILESDIR}/${PN}-2.10.0-unbreak_gnu_sed.patch"
+ "${FILESDIR}/${PN}-2.10.0-fix_wayland_build.patch"
)
src_prepare() {