summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-30 07:07:05 +0200
committerJeroen Roovers <jer@gentoo.org>2016-03-30 07:07:05 +0200
commite4fba13b659e0717b6b8d4b4680b1d806a2a6324 (patch)
tree734d16c91285e97dcd2ca2d804a32e4156f802fa /x11-misc/cbatticon/cbatticon-1.6.4.ebuild
parentmedia-gfx/fbida: Version bump. (diff)
downloadgentoo-e4fba13b659e0717b6b8d4b4680b1d806a2a6324.tar.gz
gentoo-e4fba13b659e0717b6b8d4b4680b1d806a2a6324.tar.bz2
gentoo-e4fba13b659e0717b6b8d4b4680b1d806a2a6324.zip
x11-misc/cbatticon: Version bump. Add LINGUAS support.
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-misc/cbatticon/cbatticon-1.6.4.ebuild')
-rw-r--r--x11-misc/cbatticon/cbatticon-1.6.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/cbatticon/cbatticon-1.6.4.ebuild b/x11-misc/cbatticon/cbatticon-1.6.4.ebuild
new file mode 100644
index 000000000000..680cba96af44
--- /dev/null
+++ b/x11-misc/cbatticon/cbatticon-1.6.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
+HOMEPAGE="https://github.com/ColinJones/cbatticon"
+SRC_URI="https://github.com/ColinJones/cbatticon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ strip-linguas -i .
+}
+
+src_compile() {
+ tc-export CC
+ emake \
+ $(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
+ V=1 \
+ VERSION="${PF}" \
+ WITH_GTK3=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LANGUAGES="${LINGUAS}" \
+ V=1 VERSION="${PF}" \
+ install
+
+ dodoc Changelog
+}