summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-06-07 16:14:50 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-15 00:48:35 +0200
commit8e0eb6f2c8866ef8a49918fd6b4823cafa172368 (patch)
treea36f7d69f597ec86db33d2f5ed2abd2498c848f8 /x11-misc/qps
parentlxqt-base/lxqt-qtplugin: add version 0.15.1 (diff)
downloadgentoo-8e0eb6f2c8866ef8a49918fd6b4823cafa172368.tar.gz
gentoo-8e0eb6f2c8866ef8a49918fd6b4823cafa172368.tar.bz2
gentoo-8e0eb6f2c8866ef8a49918fd6b4823cafa172368.zip
x11-misc/qps: add missing dependency on 'lxqt-base/liblxqt'
Closes: https://bugs.gentoo.org/727306 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/qps')
-rw-r--r--x11-misc/qps/qps-2.1.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/qps/qps-2.1.0-r1.ebuild b/x11-misc/qps/qps-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..0a414be68936
--- /dev/null
+++ b/x11-misc/qps/qps-2.1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Process Manager"
+HOMEPAGE="https://lxqt.github.io/"
+SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=lxqt-base/liblxqt-0.15.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}