summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-15 03:15:29 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-05-15 03:18:41 -0700
commit70fdd7b7cc08e629647a00977f4edaf25b925335 (patch)
tree7099fb587a7de68b4cac6009dd1ee0617da89089 /x11-misc/tdrop/tdrop-0.5.0.ebuild
parentdev-python/immutables: Stabilize 0.17 arm, #844793 (diff)
downloadgentoo-70fdd7b7cc08e629647a00977f4edaf25b925335.tar.gz
gentoo-70fdd7b7cc08e629647a00977f4edaf25b925335.tar.bz2
gentoo-70fdd7b7cc08e629647a00977f4edaf25b925335.zip
x11-misc/tdrop: add 0.5.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-misc/tdrop/tdrop-0.5.0.ebuild')
-rw-r--r--x11-misc/tdrop/tdrop-0.5.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/tdrop/tdrop-0.5.0.ebuild b/x11-misc/tdrop/tdrop-0.5.0.ebuild
new file mode 100644
index 000000000000..252c3456998e
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-0.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-apps/gawk
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}
+
+pkg_postinst() {
+ optfeature "tmux session support" app-misc/tmux
+}