summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-25 16:10:45 +0100
committerSam James <sam@gentoo.org>2022-04-21 20:54:32 +0100
commit68b51f9a0551ab8eb4a4690f613f2550558eedcc (patch)
treea8a1c15521d1a05dbb88baa65736bf6a94519359 /x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
parentx11-plugins/gkrellm-mailwatch: update EAPI 6 -> 8 (diff)
downloadgentoo-68b51f9a0551ab8eb4a4690f613f2550558eedcc.tar.gz
gentoo-68b51f9a0551ab8eb4a4690f613f2550558eedcc.tar.bz2
gentoo-68b51f9a0551ab8eb4a4690f613f2550558eedcc.zip
x11-plugins/gkrellm-trayicons: update EAPI 6 -> 8
Add patch to respect PKG_CONFIG. Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
new file mode 100644
index 000000000000..7cd6220fe5a7
--- /dev/null
+++ b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Configurable Tray Icons for GKrellM"
+HOMEPAGE="http://gkrellm.srcbox.net/Plugins.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch
+)
+
+src_configure() {
+ PLUGIN_SO=( trayicons$(get_modname) )
+ default
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}