summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-02 21:16:33 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-02 21:16:33 +0100
commitc59873c1b8fa28e8f40ecaa4d9a730c085a25b58 (patch)
treed78ef485c1357f32629574ba4e973a57247d7b5f /x11-plugins
parentsci-astronomy/weightwatcher: Port to EAPI 7 (diff)
downloadgentoo-c59873c1b8fa28e8f40ecaa4d9a730c085a25b58.tar.gz
gentoo-c59873c1b8fa28e8f40ecaa4d9a730c085a25b58.tar.bz2
gentoo-c59873c1b8fa28e8f40ecaa4d9a730c085a25b58.zip
x11-plugins/asclock: Port to EAPI 7
Closes: https://bugs.gentoo.org/708044 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/asclock/asclock-2.0.12-r3.ebuild17
-rw-r--r--x11-plugins/asclock/files/asclock-2.0.12-fno-common.patch21
2 files changed, 31 insertions, 7 deletions
diff --git a/x11-plugins/asclock/asclock-2.0.12-r3.ebuild b/x11-plugins/asclock/asclock-2.0.12-r3.ebuild
index 96b5e7d11f71..ef27e399a5fe 100644
--- a/x11-plugins/asclock/asclock-2.0.12-r3.ebuild
+++ b/x11-plugins/asclock/asclock-2.0.12-r3.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-IUSE=""
DESCRIPTION="Clock applet for AfterStep"
-SRC_URI="http://www.tigr.net/afterstep/download/asclock/${P}.tar.gz"
HOMEPAGE="http://tigr.net/afterstep/applets/"
+SRC_URI="http://www.tigr.net/afterstep/download/asclock/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
@@ -16,7 +16,10 @@ KEYWORDS="amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
DEPEND="x11-libs/libXpm"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-gcc41.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc41.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
default
@@ -59,7 +62,7 @@ src_install() {
insinto ${themesdir}
doins -r themes/*
dodoc README README.THEMES TODO
- cd "${D}"/${themesdir} || die
- rm -f Freeamp/Makefile{,.*} || die
+ cd "${ED}"/${themesdir} || die
+ rm Freeamp/Makefile{,.*} || die
ln -s classic default_theme || die
}
diff --git a/x11-plugins/asclock/files/asclock-2.0.12-fno-common.patch b/x11-plugins/asclock/files/asclock-2.0.12-fno-common.patch
new file mode 100644
index 000000000000..39adebdf912b
--- /dev/null
+++ b/x11-plugins/asclock/files/asclock-2.0.12-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/config.c
++++ b/config.c
+@@ -1,6 +1,7 @@
+ #include "asclock.h"
+
+ extern char *Geometry;
++extern int itdocks;
+
+ /* load the variables from a predefined theme ****************************************/
+
+--- a/symbols.c
++++ b/symbols.c
+@@ -62,7 +62,7 @@ symbol config_symbols[] = {
+ { "beats_elem_height",&beats_elem_height},
+ { NULL, NULL} };
+
+-int itdocks;
++extern int itdocks;
+ int itblinks;
+ int showampm;
+