summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-20 16:41:10 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-20 17:44:09 -0500
commita68ed34dfd77c18f8d5d933573f2ef1681b22c6f (patch)
tree040342d9ab466592f4d6055029a8a45c33430a84 /x11-terms/kitty
parentgo-module.eclass: add -buildmode=pie (diff)
downloadgentoo-a68ed34dfd77c18f8d5d933573f2ef1681b22c6f.tar.gz
gentoo-a68ed34dfd77c18f8d5d933573f2ef1681b22c6f.tar.bz2
gentoo-a68ed34dfd77c18f8d5d933573f2ef1681b22c6f.zip
x11-terms/kitty: set goflags in live
Formerly ommitted given setup.py already sets some reasonable defaults, but doesn't hurt to be explicit and add =pie too (still would rather not use the eclass and some of its implicits that don't fit well here, for now anyway). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index bba4e7fe09c5..90f8d00348ee 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -105,12 +105,12 @@ src_prepare() {
# test may fail/hang depending on environment and shell initialization scripts
rm kitty_tests/{shell_integration,ssh}.py || die
-
}
src_compile() {
tc-export CC
- export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+ local -x GOFLAGS="-buildmode=pie -v -x"
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(
--disable-link-time-optimization