summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/librvp/librvp-0.9.7.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-im/librvp/librvp-0.9.7.ebuild b/net-im/librvp/librvp-0.9.7.ebuild
index 69563f1ad40e..b87866183e5c 100644
--- a/net-im/librvp/librvp-0.9.7.ebuild
+++ b/net-im/librvp/librvp-0.9.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,13 +10,19 @@ SRC_URI="https://www.waider.ie/hacks/workshop/c/rvp/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="net-im/pidgin[gtk]"
DEPEND="virtual/pkgconfig
${RDEPEND}"
src_configure() {
- econf --with-gaim-plugin-dir="${EPREFIX}"/usr/$(get_libdir)/pidgin \
- --with-gaim-data-dir="${EPREFIX}"/usr/share/pixmaps/pidgin
+ econf \
+ --with-gaim-plugin-dir="${EPREFIX}"/usr/$(get_libdir)/pidgin \
+ --with-gaim-data-dir="${EPREFIX}"/usr/share/pixmaps/pidgin \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
}