summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/rpm/rpm-4.14.1.ebuild7
-rw-r--r--profiles/arch/alpha/package.use.mask4
-rw-r--r--profiles/arch/arm/package.use.mask4
-rw-r--r--profiles/arch/arm64/package.use.mask4
-rw-r--r--profiles/arch/ia64/package.use.mask4
5 files changed, 22 insertions, 1 deletions
diff --git a/app-arch/rpm/rpm-4.14.1.ebuild b/app-arch/rpm/rpm-4.14.1.ebuild
index 1fc3b937c5be..00c3cbeb2eb4 100644
--- a/app-arch/rpm/rpm-4.14.1.ebuild
+++ b/app-arch/rpm/rpm-4.14.1.ebuild
@@ -16,7 +16,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl caps doc lua nls python selinux"
+IUSE="acl caps doc lua nls python selinux test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
CDEPEND="!app-arch/rpm5
@@ -40,6 +40,7 @@ DEPEND="${CDEPEND}
nls? ( sys-devel/gettext )
doc? ( app-doc/doxygen )
virtual/pkgconfig
+ test? ( sys-apps/fakechroot )
"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-rpm )
@@ -106,6 +107,10 @@ src_install() {
perl_delete_localpod
}
+src_test() {
+ emake check
+}
+
pkg_postinst() {
if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
einfo "RPM database found... Rebuilding database (may take a while)..."
diff --git a/profiles/arch/alpha/package.use.mask b/profiles/arch/alpha/package.use.mask
index 5e27b1349ab6..9dc1afa26544 100644
--- a/profiles/arch/alpha/package.use.mask
+++ b/profiles/arch/alpha/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# Thomas Deutschmann <whissi@gentoo.org> (06 Jun 2018)
+# Needs sys-apps/fakechroot which isn't keyworded
+app-arch/rpm test
+
# Tomáš Mózes <hydrapolic@gmail.com> (05 Jun 2018)
# Unkeyworded dependencies.
app-admin/syslog-ng amqp mongodb
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 975f98ca998e..a8638afdd530 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# Thomas Deutschmann <whissi@gentoo.org> (06 Jun 2018)
+# Needs sys-apps/fakechroot which isn't keyworded
+app-arch/rpm test
+
# Andreas Sturmlechner <asturm@gentoo.org> (03 Jun 2018)
# net-wireless/soapysdr not keyworded
net-wireless/gr-osmosdr soapy
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index ee9cb80813ef..c859a1044c81 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# Thomas Deutschmann <whissi@gentoo.org> (06 Jun 2018)
+# Needs sys-apps/fakechroot which isn't keyworded
+app-arch/rpm test
+
# Alex Bennee <alex@bennee.com> (31 May 2018)
# bunch of dev-perl packages not yet keyworded
# and the i3 ebuild currently has RESTRICT="test" due to upstream bug
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index d38ac61fcce9..acf5931ca845 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# Thomas Deutschmann <whissi@gentoo.org> (06 Jun 2018)
+# Needs sys-apps/fakechroot which isn't keyworded
+app-arch/rpm test
+
# Michał Górny <mgorny@gentoo.org> (15 Apr 2018)
# Unkeyworded deps.
net-misc/curl curl_ssl_axtls