summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-video-vesa/Manifest1
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/Manifest b/x11-drivers/xf86-video-vesa/Manifest
index b8f5910c27d7..86ef119e0549 100644
--- a/x11-drivers/xf86-video-vesa/Manifest
+++ b/x11-drivers/xf86-video-vesa/Manifest
@@ -1 +1,2 @@
DIST xf86-video-vesa-2.5.0.tar.bz2 304322 BLAKE2B aee8b59d769a72fb2890bbadde7fb87e2f527fb58eaf8b2ef515b0a1b7dc591c6afaf1d8692caaaefb741f475ed77bc0ed069be43a752103260bc85314a7a830 SHA512 36fd921f54f33eb25966b5f9ea1e1b3e9009965c012c8b9c676686b472111719921b80cf62dafc746058878253e21f0ef341a2ff2d650df22ca1e35e81716a8b
+DIST xf86-video-vesa-2.6.0.tar.xz 275572 BLAKE2B 18a4aae9125c03da183aea07403c2e0809adf18c963c4acda8b55130a2a22c9fa1b0dc02dbb3ea836a4e735396a660a1e55bec6482707c019f9bfd756442d6b9 SHA512 494e117c1e6e0ce4c66ac7798de54667862c62605bfd76dd9373447d40dcd0521100810c9285cbe9c159440e217954c0cad6d5219c5894e075509c7c0bc353c7
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
new file mode 100644
index 000000000000..a74450947e1d
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit linux-info xorg-3
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~x86"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}