summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/ktp-auth-handler/Manifest1
-rw-r--r--kde-apps/ktp-auth-handler/ktp-auth-handler-20.08.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/ktp-auth-handler/Manifest b/kde-apps/ktp-auth-handler/Manifest
index 668783c84e8a..5c688678412c 100644
--- a/kde-apps/ktp-auth-handler/Manifest
+++ b/kde-apps/ktp-auth-handler/Manifest
@@ -1 +1,2 @@
DIST ktp-auth-handler-20.04.3.tar.xz 46332 BLAKE2B bc2e8bccea6f61c35054be72f2f3c728024304f47e78b2e82a0c5962930806dc02cccc1c371bdd758489e3a8c4f7d72d1b27cd171e1564c23e08a6c9c70dce6c SHA512 83c4c525810b0a4aeea65fa4c7342905c3c5d71d3194e4aea1d77f4e2a876f78e48639a10d84ca137a59ba930ac95d4376765aa1cdc7b94d98c3e02a5485f1f5
+DIST ktp-auth-handler-20.08.0.tar.xz 46360 BLAKE2B 4cdd6b9ff6335700580f8a76de3b159cc93a8ce6bdda5d255165cb717092f2831d05d79db8e3f0faeb616909f3e915598a1422217cce5f6fa91722601129e11e SHA512 7264b6c3f1dc4aa176386000fe295fb830c4165f2f80d50aaa3c2729171fdf4f9359a6cc1b593a60212e25384ea399d438a16a19da9aec9bdebdb3a89067808b
diff --git a/kde-apps/ktp-auth-handler/ktp-auth-handler-20.08.0.ebuild b/kde-apps/ktp-auth-handler/ktp-auth-handler-20.08.0.ebuild
new file mode 100644
index 000000000000..919d7098a5e9
--- /dev/null
+++ b/kde-apps/ktp-auth-handler/ktp-auth-handler-20.08.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.72.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="KDE Telepathy authentication handler"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-crypt/qca:2[qt5(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/kaccounts-integration-${PVCUT}:5
+ >=kde-apps/ktp-common-internals-${PVCUT}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+RDEPEND="${DEPEND}
+ app-crypt/qca:2[ssl]
+"