summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cgkit/Manifest2
-rw-r--r--dev-python/cgkit/cgkit-2.0.0-r1.ebuild85
-rw-r--r--dev-python/cgkit/cgkit-2.0.0-r2.ebuild92
-rw-r--r--dev-python/cgkit/files/cgkit-2.0.0-fix-build-system.patch40
-rw-r--r--dev-python/cgkit/files/cgkit-2.0.0-fix-c++14.patch33
-rw-r--r--dev-python/cgkit/files/cgkit-py2k-pillow.patch82
-rw-r--r--dev-python/cgkit/files/cgkit-py3k-pillow.patch82
-rw-r--r--dev-python/cgkit/metadata.xml18
-rw-r--r--profiles/package.mask7
9 files changed, 0 insertions, 441 deletions
diff --git a/dev-python/cgkit/Manifest b/dev-python/cgkit/Manifest
deleted file mode 100644
index 0032157459fd..000000000000
--- a/dev-python/cgkit/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST cgkit-2.0.0-py2k.tar.gz 885682 BLAKE2B f32eb8f05197ae44b3a1d5bf734d779c6e7f53af526f1686348e977f55bc584f565eea9e3831f562dae6aa6715d732465e0d37b07746065e965f945ee1152d18 SHA512 44e57cafc3ba3aa824c44fe4ad04f350dfe053cafa09523acab220e8a5db45dde042b4fcc3e444dc3c248a43ddd94faac6875f579c2063e6c8feba7841472f7c
-DIST cgkit-2.0.0-py3k.tar.gz 885012 BLAKE2B fe48d57ec01ee286c0974b53e088f74db73a19d6cdf9ebde43f3190a46994c803f870f2546583cf6d4bce984895469f61a82e99e6bf98da77443b3857b70b60e SHA512 0c721d728e2cacb3a5518bfdf49810793a7e4a7efdec54a95d9b8b64099996452a08193c90e1b76f57852c3593bf07e4361ba20c17ea3565413d4997e9cf6c2e
diff --git a/dev-python/cgkit/cgkit-2.0.0-r1.ebuild b/dev-python/cgkit/cgkit-2.0.0-r1.ebuild
deleted file mode 100644
index da0ba8bbd4f0..000000000000
--- a/dev-python/cgkit/cgkit-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1 scons-utils toolchain-funcs
-
-MY_P="${P/_/}"
-
-DESCRIPTION="Python library for creating 3D images"
-HOMEPAGE="http://cgkit.sourceforge.net"
-SRC_URI="
- $(python_gen_cond_dep mirror://sourceforge/${PN}/${PN}/${P}/${P}-py2k.tar.gz 'python2*')
- $(python_gen_cond_dep mirror://sourceforge/${PN}/${PN}/${P}/${P}-py3k.tar.gz 'python3*')"
-
-LICENSE="LGPL-2.1 MPL-1.1 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="3ds"
-
-RDEPEND="
- >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pyprotocols[${PYTHON_USEDEP}]' 'python2*')
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- 3ds? ( ~media-libs/lib3ds-1.3.0 )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- cgkit_unpack() {
- local tarball
- if python_is_python3; then
- tarball=${P}-py3k.tar.gz
- else
- tarball=${P}-py2k.tar.gz
- fi
- mkdir "${BUILD_DIR}" || die
- tar -C "${BUILD_DIR}" -x --strip-components 1 -f "${DISTDIR}/${tarball}" || die
- }
- python_foreach_impl cgkit_unpack
- mkdir "${S}" || die
-}
-
-python_prepare() {
- eapply \
- "${FILESDIR}"/${PN}-2.0.0-fix-build-system.patch \
- "${FILESDIR}"/${PN}-2.0.0-fix-c++14.patch
- if python_is_python3; then
- eapply "${FILESDIR}"/${PN}-py3k-pillow.patch
- else
- eapply "${FILESDIR}"/${PN}-py2k-pillow.patch
- fi
-
- cp config_template.cfg config.cfg || die
- cat >> config.cfg <<- _EOF_ || die
- BOOST_LIB = 'boost_python-${EPYTHON#python}'
- LIBS += ['GL', 'GLU', 'glut']
- LIB3DS_AVAILABLE = $(usex 3ds True False)
- _EOF_
-
- # Remove invalid test
- rm -f unittests/test_pointcloud.py || die
-}
-
-python_configure_all() {
- tc-export AR CXX
-}
-
-python_compile() {
- pushd supportlib >/dev/null || die
- CXXFLAGS="${CXXFLAGS} -fPIC" escons
- popd >/dev/null || die
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd unittests >/dev/null || die
- mkdir tmp || die
- "${EPYTHON}" all.py || die "Testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
diff --git a/dev-python/cgkit/cgkit-2.0.0-r2.ebuild b/dev-python/cgkit/cgkit-2.0.0-r2.ebuild
deleted file mode 100644
index 0edbc19a9c5f..000000000000
--- a/dev-python/cgkit/cgkit-2.0.0-r2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1 scons-utils toolchain-funcs
-
-MY_P="${P/_/}"
-
-DESCRIPTION="Python library for creating 3D images"
-HOMEPAGE="http://cgkit.sourceforge.net"
-SRC_URI="
- $(python_gen_cond_dep mirror://sourceforge/${PN}/${PN}/${P}/${P}-py2k.tar.gz 'python2*')
- $(python_gen_cond_dep mirror://sourceforge/${PN}/${PN}/${P}/${P}-py3k.tar.gz 'python3*')"
-
-LICENSE="LGPL-2.1 MPL-1.1 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="3ds"
-
-RDEPEND="
- >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pyprotocols[${PYTHON_USEDEP}]' 'python2*')
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- 3ds? ( ~media-libs/lib3ds-1.3.0 )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- cgkit_unpack() {
- local tarball
- if python_is_python3; then
- tarball=${P}-py3k.tar.gz
- else
- tarball=${P}-py2k.tar.gz
- fi
- mkdir "${BUILD_DIR}" || die
- tar -C "${BUILD_DIR}" -x --strip-components 1 -f "${DISTDIR}/${tarball}" || die
- }
- python_foreach_impl cgkit_unpack
- mkdir "${S}" || die
-}
-
-python_prepare() {
- eapply \
- "${FILESDIR}"/${PN}-2.0.0-fix-build-system.patch \
- "${FILESDIR}"/${PN}-2.0.0-fix-c++14.patch
- if python_is_python3; then
- eapply "${FILESDIR}"/${PN}-py3k-pillow.patch
- else
- eapply "${FILESDIR}"/${PN}-py2k-pillow.patch
- fi
-
- local boostpy_ver="${EPYTHON#python}"
- if has_version ">=dev-libs/boost-1.70"; then
- boostpy_ver="${boostpy_ver/\.}"
- else
- boostpy_ver="-${boostpy_ver}"
- fi
-
- cp config_template.cfg config.cfg || die
- cat >> config.cfg <<- _EOF_ || die
- BOOST_LIB = 'boost_python${boostpy_ver}'
- LIBS += ['GL', 'GLU', 'glut']
- LIB3DS_AVAILABLE = $(usex 3ds True False)
- _EOF_
-
- # Remove invalid test
- rm -f unittests/test_pointcloud.py || die
-}
-
-python_configure_all() {
- tc-export AR CXX
-}
-
-python_compile() {
- pushd supportlib >/dev/null || die
- CXXFLAGS="${CXXFLAGS} -fPIC" escons
- popd >/dev/null || die
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd unittests >/dev/null || die
- mkdir tmp || die
- "${EPYTHON}" all.py || die "Testing failed with ${EPYTHON}"
- popd >/dev/null || die
-}
diff --git a/dev-python/cgkit/files/cgkit-2.0.0-fix-build-system.patch b/dev-python/cgkit/files/cgkit-2.0.0-fix-build-system.patch
deleted file mode 100644
index 2b62071380c1..000000000000
--- a/dev-python/cgkit/files/cgkit-2.0.0-fix-build-system.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Make scons respect user variables
-
---- a/setup.py
-+++ b/setup.py
-@@ -214,7 +214,7 @@
-
- # The following variables are used to customize the compile process
-
--INC_DIRS = []
-+INC_DIRS = ['/usr/include']
- LIB_DIRS = []
- LIBS = []
- CC_ARGS = []
---- a/supportlib/SConstruct
-+++ b/supportlib/SConstruct
-@@ -30,19 +30,11 @@
- # Add the local 'include' directory...
- env.Append(CPPPATH = ["include"])
-
--# Do platform specific stuff...
--if sys.platform=="win32":
-- env.Append(CCFLAGS = ["/GX", "/GR", "/MD", "/W3"])
-- env.Append(CPPDEFINES = ["WIN32", "_LIB"])
--elif sys.platform=="darwin":
-- env.Append(CCFLAGS = ["-arch", "x86_64"])
-- env.Append(CCFLAGS = ["-arch", "i386"])
--# env.Append(CCFLAGS = ["-arch", "ppc"])
-- env.Append(CPPPATH = ["/opt/local/include"])
-- env.Append(CCFLAGS = ["-fPIC"])
--else:
-- env.Append(CPPPATH = ["/opt/local/include"])
-- env.Append(CCFLAGS = ["-fPIC"])
-+env.Append(CPPPATH = ['/usr/include'])
-+env['AR'] = os.environ.get('AR', 'ar')
-+env['CXX'] = os.environ.get('CXX', 'g++')
-+env['CXXFLAGS'] = os.environ.get('CXXFLAGS', '-fPIC')
-+env['CPPFLAGS'] = os.environ.get('CPPFLAGS', '')
-
- # Setup the help message
- Help(vars.GenerateHelpText(env))
diff --git a/dev-python/cgkit/files/cgkit-2.0.0-fix-c++14.patch b/dev-python/cgkit/files/cgkit-2.0.0-fix-c++14.patch
deleted file mode 100644
index 70f794664e81..000000000000
--- a/dev-python/cgkit/files/cgkit-2.0.0-fix-c++14.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix building in C++14 mode
-
---- a/wrappers/py_geoms1.cpp
-+++ b/wrappers/py_geoms1.cpp
-@@ -142,7 +142,7 @@
- string name = it->first;
- const PrimVarInfo& info = it->second;
- it++;
-- return make_tuple(name, info.storage, info.type, info.multiplicity);
-+ return boost::python::make_tuple(name, info.storage, info.type, info.multiplicity);
- }
- }
-
-@@ -163,7 +163,7 @@
- }
- else
- {
-- return make_tuple(name, info->storage, info->type, info->multiplicity);
-+ return boost::python::make_tuple(name, info->storage, info->type, info->multiplicity);
- }
- }
-
---- a/wrappers/py_slot.h
-+++ b/wrappers/py_slot.h
-@@ -40,7 +40,7 @@
- // .def("onValueChanged", &Slot<double>::onValueChanged, &SlotWrapper<double>::base_onValueChanged)
-
- // This macro can be used to create a new Python array slot type
--#define ARRAYSLOT(sname,stype) class_<_ArraySlotIterator<stype> >("_"sname"_Iterator", init<ArraySlot<stype>&>()) \
-+#define ARRAYSLOT(sname,stype) class_<_ArraySlotIterator<stype> >("_" sname "_Iterator", init<ArraySlot<stype>&>()) \
- .def("__iter__", &_ArraySlotIterator<stype>::__iter__) \
- .def("next", &_ArraySlotIterator<stype>::next) \
- ; \
diff --git a/dev-python/cgkit/files/cgkit-py2k-pillow.patch b/dev-python/cgkit/files/cgkit-py2k-pillow.patch
deleted file mode 100644
index 0cddbd60b868..000000000000
--- a/dev-python/cgkit/files/cgkit-py2k-pillow.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 83cb693954f6f56e50a1aa90d935e94e9e8bac8e Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Wed, 5 Jun 2013 20:39:05 -0400
-Subject: [PATCH] Update PIL imports for compatibility with Pillow
-
----
- cgkit/_Image.py | 2 +-
- cgkit/_ImageDraw.py | 2 +-
- cgkit/riutil.py | 2 +-
- utilities/checkenv.py | 2 +-
- utilities/postbake.py | 3 ++-
- 5 files changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/cgkit/_Image.py b/cgkit/_Image.py
-index 7266d4b..0122cd2 100644
---- a/cgkit/_Image.py
-+++ b/cgkit/_Image.py
-@@ -38,7 +38,7 @@
- try:
-
- # Try to import the original module...
-- from Image import *
-+ from PIL.Image import *
-
- except ImportError:
-
-diff --git a/cgkit/_ImageDraw.py b/cgkit/_ImageDraw.py
-index dfd6cf8..d1d3cff 100644
---- a/cgkit/_ImageDraw.py
-+++ b/cgkit/_ImageDraw.py
-@@ -38,7 +38,7 @@
- try:
-
- # Try to import the original module...
-- from ImageDraw import *
-+ from PIL.ImageDraw import *
-
- except ImportError:
-
-diff --git a/cgkit/riutil.py b/cgkit/riutil.py
-index 301e0f6..ae373c3 100644
---- a/cgkit/riutil.py
-+++ b/cgkit/riutil.py
-@@ -38,7 +38,7 @@ import types, sys, getpass
- from cgtypes import vec3
- from ri import *
- try:
-- import Image
-+ from PIL import Image
- _PIL_installed = 1
- except ImportError:
- _PIL_installed = 0
-diff --git a/utilities/checkenv.py b/utilities/checkenv.py
-index b95dbf7..c93235e 100644
---- a/utilities/checkenv.py
-+++ b/utilities/checkenv.py
-@@ -96,7 +96,7 @@ visualize them. You can obtain PyOpenGL at http://pyopengl.sourceforge.net/
- # Check PIL
- chkmsg("PIL")
- try:
-- import Image
-+ from PIL import Image
- print "is installed"
- except:
- print "missing"
-diff --git a/utilities/postbake.py b/utilities/postbake.py
-index cadd11d..74f894a 100644
---- a/utilities/postbake.py
-+++ b/utilities/postbake.py
-@@ -34,7 +34,8 @@
- #
- # ***** END LICENSE BLOCK *****
-
--import sys, optparse, Image
-+import sys, optparse
-+from PIL import Image
-
- # shift
- def shift(img, dx, dy):
---
-1.8.2.1
-
diff --git a/dev-python/cgkit/files/cgkit-py3k-pillow.patch b/dev-python/cgkit/files/cgkit-py3k-pillow.patch
deleted file mode 100644
index 734ff6eb356a..000000000000
--- a/dev-python/cgkit/files/cgkit-py3k-pillow.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 1953081269ce1cfdf29023a8590db40312c43194 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Wed, 5 Jun 2013 20:39:05 -0400
-Subject: [PATCH] Update PIL imports for compatibility with Pillow
-
----
- cgkit/_Image.py | 2 +-
- cgkit/_ImageDraw.py | 2 +-
- cgkit/riutil.py | 2 +-
- utilities/checkenv.py | 2 +-
- utilities/postbake.py | 3 ++-
- 5 files changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/cgkit/_Image.py b/cgkit/_Image.py
-index 7266d4b..0122cd2 100644
---- a/cgkit/_Image.py
-+++ b/cgkit/_Image.py
-@@ -38,7 +38,7 @@
- try:
-
- # Try to import the original module...
-- from Image import *
-+ from PIL.Image import *
-
- except ImportError:
-
-diff --git a/cgkit/_ImageDraw.py b/cgkit/_ImageDraw.py
-index dfd6cf8..d1d3cff 100644
---- a/cgkit/_ImageDraw.py
-+++ b/cgkit/_ImageDraw.py
-@@ -38,7 +38,7 @@
- try:
-
- # Try to import the original module...
-- from ImageDraw import *
-+ from PIL.ImageDraw import *
-
- except ImportError:
-
-diff --git a/cgkit/riutil.py b/cgkit/riutil.py
-index b51f192..ae0fba2 100644
---- a/cgkit/riutil.py
-+++ b/cgkit/riutil.py
-@@ -38,7 +38,7 @@ import types, sys, getpass
- from .cgtypes import vec3
- from .ri import *
- try:
-- import Image
-+ from PIL import Image
- _PIL_installed = 1
- except ImportError:
- _PIL_installed = 0
-diff --git a/utilities/checkenv.py b/utilities/checkenv.py
-index dda600f..8b6f74e 100644
---- a/utilities/checkenv.py
-+++ b/utilities/checkenv.py
-@@ -96,7 +96,7 @@ visualize them. You can obtain PyOpenGL at http://pyopengl.sourceforge.net/
- # Check PIL
- chkmsg("PIL")
- try:
-- import Image
-+ from PIL import Image
- print("is installed")
- except:
- print("missing")
-diff --git a/utilities/postbake.py b/utilities/postbake.py
-index 90e3140..27728c2 100644
---- a/utilities/postbake.py
-+++ b/utilities/postbake.py
-@@ -34,7 +34,8 @@
- #
- # ***** END LICENSE BLOCK *****
-
--import sys, optparse, Image
-+import sys, optparse
-+from PIL import Image
-
- # shift
- def shift(img, dx, dy):
---
-1.8.2.1
-
diff --git a/dev-python/cgkit/metadata.xml b/dev-python/cgkit/metadata.xml
deleted file mode 100644
index b5c29ce8fc23..000000000000
--- a/dev-python/cgkit/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <use>
- <flag name="3ds">Enable support for importing 3D Studio models</flag>
- </use>
- <longdescription>Python library for creating 3D images</longdescription>
- <longdescription lang="ja">
- 3D画像を作成するためのPython言語ライブラリです。
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">cgkit</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index f10247bb6d63..9e74091d4480 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -456,13 +456,6 @@ dev-perl/NetxAP
# Removal in 30 days
app-emulation/wine-any
-# David Seifert <soap@gentoo.org> (2019-10-12)
-# Last release over 6.5 years ago, no code activity.
-# Scons build system very brittle, python 3 impl bumps
-# painful, no python 3.7, No reverse dependencies.
-# Removal in 30 days. Bug #683140, #690800.
-dev-python/cgkit
-
# Mike Gilbert <floppym@gentoo.org> (2019-10-11)
# Inactive upstream for many years.
# Several open bugs.