summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/iperf/iperf-2.0.13.ebuild6
-rw-r--r--net-misc/iperf/iperf-2.0.14a.ebuild7
-rw-r--r--net-misc/iperf/iperf-2.99999.99999.ebuild8
-rw-r--r--net-misc/iperf/iperf-3.6.ebuild11
-rw-r--r--net-misc/iperf/iperf-3.9-r1.ebuild10
-rw-r--r--net-misc/iperf/iperf-3.99999.99999.ebuild14
6 files changed, 33 insertions, 23 deletions
diff --git a/net-misc/iperf/iperf-2.0.13.ebuild b/net-misc/iperf/iperf-2.0.13.ebuild
index 865bc2202da2..61b348fe5ba4 100644
--- a/net-misc/iperf/iperf-2.0.13.ebuild
+++ b/net-misc/iperf/iperf-2.0.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,8 @@ SLOT="2"
KEYWORDS="amd64 ~arm ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="ipv6 threads debug"
-DOCS="INSTALL README"
+DOCS=( "INSTALL README" )
+
PATCHES=(
"${FILESDIR}"/${PN}-2.0.12-ipv6.patch
)
@@ -26,6 +27,7 @@ src_configure() {
src_install() {
default
+
dodoc doc/*
newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
diff --git a/net-misc/iperf/iperf-2.0.14a.ebuild b/net-misc/iperf/iperf-2.0.14a.ebuild
index 6c6936429add..dd006a9af9fb 100644
--- a/net-misc/iperf/iperf-2.0.14a.ebuild
+++ b/net-misc/iperf/iperf-2.0.14a.ebuild
@@ -2,23 +2,25 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
HOMEPAGE="https://sourceforge.net/projects/iperf2/"
SRC_URI="mirror://sourceforge/${PN}2/${PN}-2.0.13.tar.gz"
+S="${WORKDIR}/${PN}-2.0.13"
LICENSE="HPND"
SLOT="2"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="ipv6 threads debug"
-DOCS="INSTALL README"
+DOCS=( "INSTALL README" )
+
PATCHES=(
"${FILESDIR}"/${PN}-2.0.12-ipv6.patch
"${FILESDIR}"/${P}.patch
)
-S=${WORKDIR}/${PN}-2.0.13
src_configure() {
econf \
@@ -33,6 +35,7 @@ src_compile() {
src_install() {
default
+
dodoc doc/*
newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
diff --git a/net-misc/iperf/iperf-2.99999.99999.ebuild b/net-misc/iperf/iperf-2.99999.99999.ebuild
index 5d1c5b42d4a4..1b3a8b85af0b 100644
--- a/net-misc/iperf/iperf-2.99999.99999.ebuild
+++ b/net-misc/iperf/iperf-2.99999.99999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit git-r3 toolchain-funcs
DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
@@ -10,10 +11,10 @@ EGIT_REPO_URI="https://git.code.sf.net/p/iperf2/code"
LICENSE="HPND"
SLOT="2"
-KEYWORDS=""
IUSE="ipv6 threads debug"
-DOCS="INSTALL README"
+DOCS=( "INSTALL README" )
+
PATCHES=(
"${FILESDIR}"/${PN}-2.0.12-ipv6.patch
)
@@ -31,6 +32,7 @@ src_compile() {
src_install() {
default
+
dodoc doc/*
newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
diff --git a/net-misc/iperf/iperf-3.6.ebuild b/net-misc/iperf/iperf-3.6.ebuild
index 15805e3908a0..29d741996fe7 100644
--- a/net-misc/iperf/iperf-3.6.ebuild
+++ b/net-misc/iperf/iperf-3.6.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit autotools eutils ltprune
DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
HOMEPAGE="https://github.com/esnet/iperf/"
SRC_URI="https://github.com/esnet/iperf/archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_/}"
LICENSE="BSD"
SLOT="3"
@@ -18,9 +20,9 @@ DEPEND="!libressl? ( dev-libs/openssl:0= )
sctp? ( net-misc/lksctp-tools )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P/_/}
-
-PATCHES=( "${FILESDIR}"/${PN}-3.0.5-flags.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.5-flags.patch
+)
src_prepare() {
default
@@ -35,6 +37,7 @@ src_configure() {
src_install() {
default
+
newconfd "${FILESDIR}"/iperf.confd iperf3
newinitd "${FILESDIR}"/iperf3.initd iperf3
prune_libtool_files
diff --git a/net-misc/iperf/iperf-3.9-r1.ebuild b/net-misc/iperf/iperf-3.9-r1.ebuild
index 05b4323e7917..280a900bb9db 100644
--- a/net-misc/iperf/iperf-3.9-r1.ebuild
+++ b/net-misc/iperf/iperf-3.9-r1.ebuild
@@ -7,6 +7,7 @@ inherit systemd
DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
HOMEPAGE="https://github.com/esnet/iperf/"
SRC_URI="https://github.com/esnet/iperf/archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_/}"
LICENSE="BSD"
SLOT="3"
@@ -18,11 +19,9 @@ DEPEND="
libressl? ( dev-libs/libressl:0= )
sctp? ( net-misc/lksctp-tools )
"
-RDEPEND="
- ${DEPEND}
-"
-S=${WORKDIR}/${P/_/}
-DOCS="README.md RELNOTES.md"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md RELNOTES.md" )
src_configure() {
econf \
@@ -32,6 +31,7 @@ src_configure() {
src_install() {
default
+
newconfd "${FILESDIR}"/iperf.confd iperf3
newinitd "${FILESDIR}"/iperf3.initd iperf3
systemd_dounit contrib/iperf3.service
diff --git a/net-misc/iperf/iperf-3.99999.99999.ebuild b/net-misc/iperf/iperf-3.99999.99999.ebuild
index 14dfc1e065cd..837cb0d0c3a2 100644
--- a/net-misc/iperf/iperf-3.99999.99999.ebuild
+++ b/net-misc/iperf/iperf-3.99999.99999.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools git-r3
DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
HOMEPAGE="https://github.com/esnet/iperf/"
EGIT_REPO_URI="https://github.com/esnet/iperf/"
+S="${WORKDIR}/${P/_/}"
LICENSE="BSD"
SLOT="3"
-KEYWORDS=""
IUSE="libressl sctp static-libs"
DEPEND="
@@ -18,11 +19,9 @@ DEPEND="
libressl? ( dev-libs/libressl:0= )
sctp? ( net-misc/lksctp-tools )
"
-RDEPEND="
- ${DEPEND}
-"
-S=${WORKDIR}/${P/_/}
-DOCS="README.md RELNOTES.md"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md RELNOTES.md" )
src_configure() {
econf \
@@ -32,6 +31,7 @@ src_configure() {
src_install() {
default
+
newconfd "${FILESDIR}"/iperf.confd iperf3
newinitd "${FILESDIR}"/iperf3.initd iperf3
find "${ED}" -name '*.la' -delete || die