summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/llvm/files/llvm-3.8-lldb_six.patch13
-rw-r--r--sys-devel/llvm/llvm-3.8.0.ebuild3
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-devel/llvm/files/llvm-3.8-lldb_six.patch b/sys-devel/llvm/files/llvm-3.8-lldb_six.patch
new file mode 100644
index 000000000000..324f2b8935bb
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-3.8-lldb_six.patch
@@ -0,0 +1,13 @@
+diff -Naur llvm-3.8.0.src.orig/tools/lldb/scripts/Python/finishSwigPythonLLDB.py llvm-3.8.0.src/tools/lldb/scripts/Python/finishSwigPythonLLDB.py
+--- llvm-3.8.0.src.orig/tools/lldb/scripts/Python/finishSwigPythonLLDB.py 2015-12-11 16:43:36.000000000 +0100
++++ llvm-3.8.0.src/tools/lldb/scripts/Python/finishSwigPythonLLDB.py 2016-03-09 14:12:15.614483414 +0100
+@@ -720,9 +720,6 @@
+ bOk, strMsg = create_symlinks(vDictArgs, strFrameworkPythonDir)
+
+ if bOk:
+- bOk, strMsg = copy_six(vDictArgs, strFrameworkPythonDir)
+-
+- if bOk:
+ bOk, strMsg = copy_lldbpy_file_to_lldb_pkg_dir(vDictArgs,
+ strFrameworkPythonDir,
+ strCfgBldDir)
diff --git a/sys-devel/llvm/llvm-3.8.0.ebuild b/sys-devel/llvm/llvm-3.8.0.ebuild
index b2b1ec3b6ad7..f8e26f54407e 100644
--- a/sys-devel/llvm/llvm-3.8.0.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0.ebuild
@@ -39,6 +39,7 @@ COMMON_DEPEND="
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
+ lldb? ( dev-python/six[${PYTHON_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
ocaml? (
>=dev-lang/ocaml-4.00.0:0=
@@ -216,6 +217,8 @@ src_prepare() {
# https://llvm.org/bugs/show_bug.cgi?id=18841
sed -e 's/add_subdirectory(readline)/#&/' \
-i tools/lldb/scripts/Python/modules/CMakeLists.txt || die
+ # Do not install bundled six module
+ epatch "${FILESDIR}"/${PN}-3.8-lldb_six.patch
fi
# User patches