summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/kdepim-addons/Manifest1
-rw-r--r--kde-apps/kdepim-addons/kdepim-addons-20.12.3.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/kde-apps/kdepim-addons/Manifest b/kde-apps/kdepim-addons/Manifest
index 7c39c3e3c777..5a45e3e03aa0 100644
--- a/kde-apps/kdepim-addons/Manifest
+++ b/kde-apps/kdepim-addons/Manifest
@@ -1 +1,2 @@
DIST kdepim-addons-20.12.2.tar.xz 2145492 BLAKE2B 6c143977f8e645c9fde13fb5453c292cc8b4068721cb82beac942dfa571906648b03e49e0aa69e37c8042d4a3c0cea4b5befe48716adc736b7bdbf03b0c6b4c9 SHA512 33ed5c0e6444c292f78767c32778ac11a4d1e567c7fde2c85ab10016ddaa7adef7d29e2c75635b1538abf0e6f59eaeae0810b3b122c9aeadc0de407e476c7797
+DIST kdepim-addons-20.12.3.tar.xz 2145600 BLAKE2B 142a519bd57a311042ecbdd1e246a6d4b8bccd64c64d1aeb13755cd5b55383b161082fdd897ccbd2cce83a5f7e9c24b2951cf25f88b2deae90ae0da5737c169d SHA512 345febeb6cd6db60f4c5e246d0a775e828310bca50288e36ba676185404ae5dfe556262a882a201e85cad851b3612a27de15e5b9d6076ee109abdb01e4909058
diff --git a/kde-apps/kdepim-addons/kdepim-addons-20.12.3.ebuild b/kde-apps/kdepim-addons/kdepim-addons-20.12.3.ebuild
new file mode 100644
index 000000000000..16a173a9f36e
--- /dev/null
+++ b/kde-apps/kdepim-addons/kdepim-addons-20.12.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Plugins for KDE Personal Information Management Suite"
+HOMEPAGE="https://apps.kde.org/en/kontact"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="importwizard markdown"
+
+RDEPEND="
+ >=app-crypt/gpgme-1.11.1[cxx,qt5]
+ >=dev-libs/grantlee-5.2.0:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-notes-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/eventviews-${PVCUT}:5
+ >=kde-apps/grantleetheme-${PVCUT}:5
+ >=kde-apps/incidenceeditor-${PVCUT}:5
+ >=kde-apps/kaddressbook-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kimap-${PVCUT}:5
+ >=kde-apps/kitinerary-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kontactinterface-${PVCUT}:5
+ >=kde-apps/kpkpass-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-apps/libksieve-${PVCUT}:5
+ >=kde-apps/libktnef-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ importwizard? ( >=kde-apps/akonadi-import-wizard-${PVCUT}:5 )
+ markdown? ( app-text/discount )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package importwizard KPimImportWizard)
+ $(cmake_use_find_package markdown Discount)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "regex support for Sieve editor plugin" kde-misc/kregexpeditor
+ fi
+ ecm_pkg_postinst
+}