summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r2.ebuild (renamed from app-admin/webapp-config/webapp-config-1.55-r1.ebuild)8
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.55-r1.ebuild b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
index 49c4a1068751..08e686f810cf 100644
--- a/app-admin/webapp-config/webapp-config-1.55-r1.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.55-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1 prefix
@@ -51,12 +52,11 @@ python_install_all() {
dodoc AUTHORS
doman doc/*.[58]
- dohtml doc/*.[58].html
}
python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
- || die "Testing failed with ${EPYTHON}"
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
}
pkg_postinst() {
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 37cef6a134c9..611a6da21acf 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1 prefix
@@ -57,12 +58,11 @@ python_install_all() {
dodoc AUTHORS
doman doc/*.[58]
- dohtml doc/*.[58].html
}
python_test() {
- PYTHONPATH="." "${PYTHON}" WebappConfig/tests/external.py \
- || die "Testing failed with ${EPYTHON}"
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
}
pkg_postinst() {