summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexedit/hexedit-1.2.13.ebuild')
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
index f7a868c8eb8e..f7363a85fa12 100644
--- a/app-editors/hexedit/hexedit-1.2.13.ebuild
+++ b/app-editors/hexedit/hexedit-1.2.13.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
+inherit autotools eutils
+
DESCRIPTION="View and edit files in hex or ASCII"
HOMEPAGE="http://rigaux.org/hexedit.html"
SRC_URI="http://rigaux.org/${P}.src.tgz"
@@ -9,15 +12,20 @@ SRC_URI="http://rigaux.org/${P}.src.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 s390 sh sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
DEPEND="sys-libs/ncurses"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
src_install() {
- dobin hexedit || die "dobin failed"
+ dobin hexedit
doman hexedit.1
dodoc Changes
}