summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/google-c-style')
-rw-r--r--app-emacs/google-c-style/Manifest1
-rw-r--r--app-emacs/google-c-style/files/50google-c-style-gentoo.el5
-rw-r--r--app-emacs/google-c-style/google-c-style-20091009-r1.ebuild27
-rw-r--r--app-emacs/google-c-style/metadata.xml6
4 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/google-c-style/Manifest b/app-emacs/google-c-style/Manifest
new file mode 100644
index 000000000000..e6aba3818670
--- /dev/null
+++ b/app-emacs/google-c-style/Manifest
@@ -0,0 +1 @@
+DIST google-c-style-20091009.tar.bz2 2178 SHA256 58606847b01df277055d48ae8f013e3302bd22eebf067ad47aad289ed92da47b SHA512 5d61d6e021643ffc1468c14cdbbde0b52dc9346330983c19bdb7f4d6fb8960c662ca6198658963ff6d2b4d7d2dc96853a8c58de48da77364a860f2f777855b5a WHIRLPOOL ca42ded98e47990198be221a364b2fbc5416ae9a16f9b0843c2ff47223f7725e3aa8d406356345817be030fa05bdb24f5de97d1318f8769f45e1a37da04a79a3
diff --git a/app-emacs/google-c-style/files/50google-c-style-gentoo.el b/app-emacs/google-c-style/files/50google-c-style-gentoo.el
new file mode 100644
index 000000000000..3e9768b65db7
--- /dev/null
+++ b/app-emacs/google-c-style/files/50google-c-style-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'google-set-c-style "google-c-style"
+ "Set the current buffer's c-style to Google C/C++ Programming Style." t)
+(autoload 'google-make-newline-indent "google-c-style"
+ "Sets up preferred newline behavior." t)
diff --git a/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
new file mode 100644
index 000000000000..3ac3bc90ea32
--- /dev/null
+++ b/app-emacs/google-c-style/google-c-style-20091009-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Provides the google C/C++ coding style"
+HOMEPAGE="http://code.google.com/p/google-styleguide/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Example usage (~/.emacs):"
+ elog " (add-hook 'c-mode-common-hook 'google-set-c-style)"
+ elog " (add-hook 'c-mode-common-hook 'google-make-newline-indent)"
+}
diff --git a/app-emacs/google-c-style/metadata.xml b/app-emacs/google-c-style/metadata.xml
new file mode 100644
index 000000000000..1d4cd56fb85b
--- /dev/null
+++ b/app-emacs/google-c-style/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>chromium</herd>
+ <herd>emacs</herd>
+</pkgmetadata>