summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/nxml-svg-schemas')
-rw-r--r--app-emacs/nxml-svg-schemas/Manifest1
-rw-r--r--app-emacs/nxml-svg-schemas/files/60nxml-svg-schemas-gentoo.el5
-rw-r--r--app-emacs/nxml-svg-schemas/files/Makefile-trang6
-rw-r--r--app-emacs/nxml-svg-schemas/files/schemas.xml13
-rw-r--r--app-emacs/nxml-svg-schemas/metadata.xml8
-rw-r--r--app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild43
6 files changed, 76 insertions, 0 deletions
diff --git a/app-emacs/nxml-svg-schemas/Manifest b/app-emacs/nxml-svg-schemas/Manifest
new file mode 100644
index 000000000000..a61e6a3baa08
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/Manifest
@@ -0,0 +1 @@
+DIST w3c-svg-rng-1.1.20081123.zip 48420 SHA256 995d72804ae518363080544999ea3f356fac168e193d0967ce9944fe0f8c31cf SHA512 69e44a7c04a3af77d0fed8f19372cfcad7998e262a44b520145fe2c0ad03bf20daf57e1e97f71ff27f0e06bd3f07d1ec0b0976fdd893d77df2f82709f7c1ce1f WHIRLPOOL 706509d058a187d7581612c103a333d83cc758a0fd436686d20c8de7fe07bb7e6be63169f3c14aee662ac9475d7e7718a696d68b8cfff6a8a0adfe941712e4be
diff --git a/app-emacs/nxml-svg-schemas/files/60nxml-svg-schemas-gentoo.el b/app-emacs/nxml-svg-schemas/files/60nxml-svg-schemas-gentoo.el
new file mode 100644
index 000000000000..c574746e6576
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/files/60nxml-svg-schemas-gentoo.el
@@ -0,0 +1,5 @@
+;; This must be executed after rng-schema-locating-files
+;; is set in rng-loc (which is part of nxml-mode).
+(eval-after-load "rng-loc"
+ '(add-to-list 'rng-schema-locating-files
+ "@SITEETC@/schemas.xml"))
diff --git a/app-emacs/nxml-svg-schemas/files/Makefile-trang b/app-emacs/nxml-svg-schemas/files/Makefile-trang
new file mode 100644
index 000000000000..699cf676ff45
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/files/Makefile-trang
@@ -0,0 +1,6 @@
+# -*- makefile -*-
+
+all: $(patsubst %.rng,%.rnc,$(wildcard *.rng))
+
+%.rnc: %.rng
+ trang -I rng -O rnc $< $@
diff --git a/app-emacs/nxml-svg-schemas/files/schemas.xml b/app-emacs/nxml-svg-schemas/files/schemas.xml
new file mode 100644
index 000000000000..baebe4af596c
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/files/schemas.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="utf-8"?>
+<locatingRules xmlns="http://thaiopensource.com/ns/locating-rules/1.0">
+ <!-- This version of the locatingRules does not support having
+ enough details to distinguish between different SVG versions,
+ maybe in the future it will.
+ -->
+
+ <uri pattern="*.svg" typeId="SVG" />
+ <namespace ns="http://www.w3.org/2000/svg" typeId="SVG" />
+ <documentElement localName="svg" typeId="SVG" />
+
+ <typeId id="SVG" uri="svg11.rnc" />
+</locatingRules>
diff --git a/app-emacs/nxml-svg-schemas/metadata.xml b/app-emacs/nxml-svg-schemas/metadata.xml
new file mode 100644
index 000000000000..d0e321d9a75d
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<maintainer>
+ <email>flameeyes@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild b/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild
new file mode 100644
index 000000000000..7c0bf8a174f9
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with SVG 1.1 schemas"
+HOMEPAGE="http://www.w3.org/TR/SVG11/"
+# original SRC_URI is http://www.w3.org/Graphics/SVG/1.1/rng/rng.zip
+# but since it's unversioned, I versioned it and got it locally.
+SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/w3c-svg-rng-${PV}.zip"
+
+LICENSE="HPND"
+# In a future we might have 1.2 schemas too, but for now we can only
+# install this one anyway because the schemas.xml syntax is not
+# sophisticated enough.
+SLOT="1.1"
+KEYWORDS="amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+RDEPEND=""
+
+S="${WORKDIR}"
+SITEFILE="60${PN}-gentoo.el"
+
+src_prepare() {
+ # we don't need the doctype for our work
+ sed -i -e '/DOCTYPE grammar/d' *.rng || die "sed failed"
+}
+
+src_compile() {
+ emake -f "${FILESDIR}/Makefile-trang"
+}
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins "${FILESDIR}/schemas.xml" *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}