summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-6.1-r1.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-6.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
new file mode 100644
index 000000000000..e4db1c4174d1
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from http://bzr.sv.gnu.org/r/emacs/elpa
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+
+DEPEND="app-arch/xz-utils"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_compile() {
+ elisp-compile *.el || die
+ elisp-make-autoload-file || die
+}