summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/unoconv')
-rw-r--r--app-office/unoconv/Manifest3
-rw-r--r--app-office/unoconv/files/timeout.patch11
-rw-r--r--app-office/unoconv/metadata.xml8
-rw-r--r--app-office/unoconv/unoconv-0.6.20131229.ebuild51
-rw-r--r--app-office/unoconv/unoconv-0.6.ebuild50
-rw-r--r--app-office/unoconv/unoconv-0.7.ebuild42
-rw-r--r--app-office/unoconv/unoconv-99999999.ebuild42
7 files changed, 207 insertions, 0 deletions
diff --git a/app-office/unoconv/Manifest b/app-office/unoconv/Manifest
new file mode 100644
index 000000000000..98d63e2b9206
--- /dev/null
+++ b/app-office/unoconv/Manifest
@@ -0,0 +1,3 @@
+DIST unoconv-0.6-git.tar.gz 91694 SHA256 df687f06582dbc1768045308b1f04305ccd8f363c8b479ea188f43ca45f58c67 SHA512 c2991d65890738437c3180a8d12371b16cb045601f300ddc252b36ed2698d6412c610a2699ce94ac278987b9b26a9804eebff2df947db687637f6b3158f4b709 WHIRLPOOL ee7324ad406854d62f84dffed2d006d77cc86089f19d9b7d030770ecaf954c0c0e139b02443a24aa93acc05854d8c25e91216f8e131de953f87e443f829e7bef
+DIST unoconv-0.6.20131229-git.tar.gz 92085 SHA256 032d2bd06ca59e90d98afd1d7d95f076cec9ca0306d78139cf92695990115934 SHA512 ba347ff257cb3f77ab883491cfbc96391225179cb11efa8c26b21f36bbc2f125f9d565744fab84aa32f4ec41acd4ccc0c7b53a154c2342da9ae5dd3b6e9296bc WHIRLPOOL ca59a0f58c18cf3163712e0ff7c215d518e89020d0ca9e2241a994b1c99d0e9b17c2d52265b4ebbb23c9edf854f8041bc09678979bb96f31db791a2bb59dc2ee
+DIST unoconv-0.7.tar.gz 96151 SHA256 b3f58573aba59d3ada7d8f51cd6844b6abc20251cf89820e939dcf9b5a4eb2dc SHA512 3b0837e11f22733e0fbef93dc6aeabd0e2d3d59b6c35a6f7b29b86506a5842bcbffb3e889864d6e14c1e53dd306354690a699257fe60f36ce1d4455ab52b5df7 WHIRLPOOL 4c123ccddb68c2edfbcf20ec8606d434b8daa62726efdfc7e253ccd11fe9e26ffdece2796db34f6dd7ae5fbdf5b20c3eaa3948a749b2c5ae4b5c52a7cf5de3d0
diff --git a/app-office/unoconv/files/timeout.patch b/app-office/unoconv/files/timeout.patch
new file mode 100644
index 000000000000..f41b101faf78
--- /dev/null
+++ b/app-office/unoconv/files/timeout.patch
@@ -0,0 +1,11 @@
+--- unoconv.old 2011-08-01 14:20:45.000000000 +0200
++++ unoconv 2011-08-01 14:21:01.000000000 +0200
+@@ -534,7 +534,7 @@
+ unocontext = resolver.resolve("uno:%s" % op.connection)
+ break
+ except NoConnectException:
+- time.sleep(0.5)
++ time.sleep(5)
+ timeout += 0.5
+ except:
+ raise
diff --git a/app-office/unoconv/metadata.xml b/app-office/unoconv/metadata.xml
new file mode 100644
index 000000000000..60e7981326db
--- /dev/null
+++ b/app-office/unoconv/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <maintainer>
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/unoconv/unoconv-0.6.20131229.ebuild b/app-office/unoconv/unoconv-0.6.20131229.ebuild
new file mode 100644
index 000000000000..55d589e2e2b3
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.6.20131229.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-2"
+inherit eutils python ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="https://github.com/dagwieers/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+SRC_URI="https://github.com/dagwieers/${PN}/tarball/a2c7b2f06d799453666639382951142e0bcaad43 -> ${P}-git.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999* ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv "${WORKDIR}"/dagwieers-${PN}-* "${WORKDIR}"/${P}
+ cd "${S}"
+
+ epatch "${FILESDIR}/timeout.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog README.asciidoc || die
+}
diff --git a/app-office/unoconv/unoconv-0.6.ebuild b/app-office/unoconv/unoconv-0.6.ebuild
new file mode 100644
index 000000000000..9a82babc2505
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-2"
+inherit eutils python ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="https://github.com/dagwieers/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999* ]] || \
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv "${WORKDIR}"/dagwieers-${PN}-* "${WORKDIR}"/${P}
+ cd "${S}"
+
+ epatch "${FILESDIR}/timeout.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog README.asciidoc || die
+}
diff --git a/app-office/unoconv/unoconv-0.7.ebuild b/app-office/unoconv/unoconv-0.7.ebuild
new file mode 100644
index 000000000000..ddc3ac209ca3
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit eutils python-single-r1
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/timeout.patch"
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}" || die
+
+ dodoc ChangeLog CHANGELOG.md README.adoc || die
+}
diff --git a/app-office/unoconv/unoconv-99999999.ebuild b/app-office/unoconv/unoconv-99999999.ebuild
new file mode 100644
index 000000000000..49f8d4578756
--- /dev/null
+++ b/app-office/unoconv/unoconv-99999999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+EGIT_REPO_URI="https://github.com/dagwieers/unoconv.git"
+[[ ${PV} == 9999* ]] && SCM_ECLASS="git-2"
+inherit eutils python ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Convert between document formats supported by Libreoffice"
+HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
+[[ ${PV} == 9999* ]] || SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ ${PV} == 9999* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/timeout.patch"
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake docs-install install install-links DESTDIR="${D}" || die
+}