summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/glog/glog-0.6.0.ebuild')
-rw-r--r--dev-cpp/glog/glog-0.6.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-cpp/glog/glog-0.6.0.ebuild b/dev-cpp/glog/glog-0.6.0.ebuild
index 069eec682395..7dccfa1a63d5 100644
--- a/dev-cpp/glog/glog-0.6.0.ebuild
+++ b/dev-cpp/glog/glog-0.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2011-2023 Gentoo Authors
+# Copyright 2011-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -29,9 +29,16 @@ RDEPEND="gflags? ( dev-cpp/gflags:0=[${MULTILIB_USEDEP}] )
libunwind? (
llvm-libunwind? ( sys-libs/llvm-libunwind:0=[${MULTILIB_USEDEP}] )
!llvm-libunwind? ( sys-libs/libunwind:0=[${MULTILIB_USEDEP}] )
- )"
+ )
+"
DEPEND="${RDEPEND}
- test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
+ test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-symbolize-test.patch" # bug 863599
+ "${FILESDIR}/${P}-try-fix-logging-test.patch"
+)
src_configure() {
local mycmakeargs=(