summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/folly/folly-2024.11.04.00-r1.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild b/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
index e55339ec78a5..8406398d114d 100644
--- a/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
+++ b/dev-cpp/folly/folly-2024.11.04.00-r1.ebuild
@@ -90,5 +90,15 @@ src_test() {
'concurrency_concurrent_hash_map_test.*'
)
+ if use arm64; then
+ CMAKE_SKIP_TESTS+=(
+ # Tests are flaky/timing dependent on both QEMU chroot and real hardware
+ io_async_hh_wheel_timer_test.HHWheelTimerTest
+ # Times out on real hardware
+ concurrent_skip_list_test.ConcurrentSkipList
+ futures_retrying_test.RetryingTest.largeRetries
+ )
+ fi
+
cmake_src_test
}