summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/pe-format')
-rw-r--r--dev-dotnet/pe-format/pe-format-2.9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-dotnet/pe-format/pe-format-2.9999.ebuild b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
index 5edcc5efc0d3..d5801e1e7034 100644
--- a/dev-dotnet/pe-format/pe-format-2.9999.ebuild
+++ b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}2.git"
-inherit git-r3
+inherit autotools git-r3
#endif
-inherit autotools-utils fdo-mime systemd
+inherit fdo-mime systemd
DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
@@ -27,17 +26,21 @@ RDEPEND="!<sys-apps/openrc-0.9.4"
#if LIVE
KEYWORDS=
SRC_URI=
+
+src_prepare() {
+ eautoreconf
+}
#endif
src_configure() {
- local myeconfargs=(
+ local myconf=(
"$(systemd_with_unitdir)"
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}
src_install() {
- autotools-utils_src_install
+ default
keepdir /var/lib
}