summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbase58')
-rw-r--r--dev-libs/libbase58/Manifest2
-rw-r--r--dev-libs/libbase58/libbase58-0.1.0.ebuild27
-rw-r--r--dev-libs/libbase58/libbase58-0.1.1.ebuild27
-rw-r--r--dev-libs/libbase58/metadata.xml18
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libbase58/Manifest b/dev-libs/libbase58/Manifest
new file mode 100644
index 000000000000..6c24c1c260f8
--- /dev/null
+++ b/dev-libs/libbase58/Manifest
@@ -0,0 +1,2 @@
+DIST libbase58-0.1.1.tar.gz 6564 SHA256 51f665b52efc99b7a8205101569a0580a7d7defda1c4597e6e467c164f86a206 SHA512 c47cb7f891c54a8b07a01f033312baa97b7722965cc0c5003fb8591dedc304dd3ff408e8b31ee4b0634b58f6a7f0be55bee039a1fd8e24fdb62f7a72c4be7c3b WHIRLPOOL ec72557af9269a47a33c4d75260821b606b75a644ded2f4f30f02657fc3a6586240f91d76718b219e7cbde8a636987f5145405faa9603c2c19022aeeac1be878
+DIST v0.1.0.tar.gz 5807 SHA256 43ac21173353c3d284406986501d15972f589b6d9247f61766b7acbf1f5a7a4a SHA512 8bfeeb194736cae291308b281f23f49774943dc0151863ddf99b92b657c0151a9873a110f79679e81f14bf0ecf3cf00bf43f517a24d5e89d032a0a5ebed1a358 WHIRLPOOL ba3baed348e4e7265ad14c04f7fca9b728ebd026a61275e4aaa852268f2513bc001610f013159b72c0367255a4c2d3d69b18c7b693c5e6eab6269c4894b6667c
diff --git a/dev-libs/libbase58/libbase58-0.1.0.ebuild b/dev-libs/libbase58/libbase58-0.1.0.ebuild
new file mode 100644
index 000000000000..fa5c386094ca
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable tools tool)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/libbase58/libbase58-0.1.1.ebuild b/dev-libs/libbase58/libbase58-0.1.1.ebuild
new file mode 100644
index 000000000000..ddfff16ee8d0
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable tools tool)
+ )
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/libbase58/metadata.xml b/dev-libs/libbase58/metadata.xml
new file mode 100644
index 000000000000..47e36dad83d9
--- /dev/null
+++ b/dev-libs/libbase58/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>luke_gentoo_bitcoin@dashjr.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <use>
+ <flag name="tools">Build command line base58 tool</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">luke-jr/libbase58</remote-id>
+ </upstream>
+</pkgmetadata>