summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild')
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
index 1aceba7d26da..176e78131d70 100644
--- a/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
+++ b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,26 +7,26 @@ PYTHON_COMPAT=( python2_7 )
inherit eutils python-single-r1
-# Tests can't function after 2014-12-31 ...
-RESTRICT="test"
-
DESCRIPTION="Hyperdex macaroons support library"
-
HOMEPAGE="http://hyperdex.org"
SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-
IUSE="test +python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
-RDEPEND="dev-libs/libsodium
- dev-libs/json-c"
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libsodium
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="test? ( python )"
-
src_prepare() {
use python && python-single-r1_pkg_setup
}