summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch10
-rw-r--r--dev-libs/keystone/keystone-0.9.2-r3.ebuild1
2 files changed, 11 insertions, 0 deletions
diff --git a/dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch b/dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch
new file mode 100644
index 000000000000..ba053db30040
--- /dev/null
+++ b/dev-libs/keystone/files/keystone-0.9.2-gcc15-cstdint.patch
@@ -0,0 +1,10 @@
+--- a/llvm/include/llvm/ADT/STLExtras.h
++++ b/llvm/include/llvm/ADT/STLExtras.h
+@@ -21,6 +21,7 @@
+ #include <algorithm> // for std::all_of
+ #include <cassert>
+ #include <cstddef> // for std::size_t
++#include <cstdint>
+ #include <cstdlib> // for qsort
+ #include <functional>
+ #include <iterator>
diff --git a/dev-libs/keystone/keystone-0.9.2-r3.ebuild b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
index 3ac8106f976a..b6d645b0d8ee 100644
--- a/dev-libs/keystone/keystone-0.9.2-r3.ebuild
+++ b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
@@ -50,6 +50,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}/${P}-strict-prototypes.patch"
+ "${FILESDIR}/${PN}-0.9.2-gcc15-cstdint.patch"
)
# Upstream doesn't flag patch releases (bug 858395)