summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.3.3-r1.ebuild (renamed from dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.3.3.ebuild)18
1 files changed, 3 insertions, 15 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.3.3.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.3.3-r1.ebuild
index 692863db8e51..88142c6e203e 100644
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.3.3.ebuild
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,25 +27,12 @@ BDEPEND=">=dev-util/rocm-cmake-${PV}
test? ( >=x11-apps/mesa-progs-8.5.0[X] )
"
-PATCHES=(
- "${FILESDIR}/${PN}-3.5.0-do-not-install-libopencl.patch"
-)
-
S="${WORKDIR}/ROCm-OpenCL-Runtime-rocm-${PV}"
S1="${WORKDIR}/ROCclr-rocm-${PV}"
src_prepare() {
- # Remove "clinfo" - use "dev-util/clinfo" instead
- #[ -d tools/clinfo ] && rm -rf tools/clinfo || die
-
cmake_src_prepare
- hprefixify amdocl/CMakeLists.txt
-
- sed -e "s/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/g" -i packaging/CMakeLists.txt || die
- # remove trailing CR or it won't work
- sed -e "s/\r$//g" -i tests/ocltst/module/perf/oclperf.exclude || die
-
pushd ${S1} || die
# Bug #753377
# patch re-enables accidentally disabled gfx800 family
@@ -64,7 +51,8 @@ src_configure() {
-DROCM_PATH="${EPREFIX}/usr"
-DBUILD_TESTS=$(usex test ON OFF)
-DEMU_ENV=ON
- # -DCMAKE_STRIP=""
+ -DBUILD_ICD=OFF
+ -DFILE_REORG_BACKWARD_COMPATIBILITY=OFF
)
cmake_src_configure
}