summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild')
-rw-r--r--dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild b/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
new file mode 100644
index 000000000000..4f2748bb7f4c
--- /dev/null
+++ b/dev-lisp/c2ffi/c2ffi-9.0.0.20191017.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils llvm
+
+MY_COMMIT="15fda06de0bad97bf91f5590f7f24623eab2f580"
+
+DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
+HOMEPAGE="https://github.com/rpav/c2ffi"
+SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/clang:9=
+ sys-devel/llvm:9=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/c2ffi-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/${PN}-9.0.0.20191017-fix-lib-location.patch )