summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/xstr/xstr-0.2.1.ebuild')
-rw-r--r--dev-ml/xstr/xstr-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/xstr/xstr-0.2.1.ebuild b/dev-ml/xstr/xstr-0.2.1.ebuild
new file mode 100644
index 000000000000..6967ea122923
--- /dev/null
+++ b/dev-ml/xstr/xstr-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Thread-safe implementation of string searching/matching/splitting"
+HOMEPAGE="http://www.ocaml-programming.de/packages/"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile()
+{
+ make all || die
+ make opt || die
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc README RELEASE
+}